LO Database newbie - Firebird error trying to create new project

So I have a large board game collection, and I’m trying to create a catalog of all of the board games. I already have my collection in a spreadsheet form, but I want to generate something more attractive for not-me’s. Years ago in Appleworks I would create a database, layout where I wanted elements in a master record, and then could create a “document” from that. It appears that’s still the case today in LO, and to that end I generated a database file and attempted to use the wizard to create the different fields I would want. These are simple things like Name, Player Range, Best Players, Play Time Range, a short description, elements of the game, and mechanics of the game, all text fields because some of the numerical fields my have - ranges or , seperations. There’s also a field to hold a photo of the game box.

That’s where things initially went wrong. When I tried to “create the form”, and even when I tried the other options available to me - entering data or editing the tables - LO gave me the following error:

firebird_sdbc error:
*unsuccessful metadata update
*CREATE TABLE Game List failed
*Dynamic SQL Error
*SQL error code = -204
*Data type unknown
*Implementation limit exceeded
*COLUMN <Missing arg #1 - possibly status vector overflow>
caused by
'CREATE TABLE "Game List" ("ID" INTEGER NOT NULL,"Photo" BLOB SUB_TYPE -9546,"Name" VARCHAR(200),"Players" VARCHAR(5),"Best" VARCHAR(15),"Time" VARCHAR(20),"Description" VARCHAR(16000),"Elements" VARCHAR(800),"Mechanics" VARCHAR(800), PRIMARY KEY  ("ID"))'

I’ve installed the 12.1.? SDK from Oracle on my 10.3.6 Mac OS system. All of the fields had been entered, there were no missing arguments within the wizard. I really have no idea what happened or where to go from here, or even if this is the right way to go about doing what I want.

I could not register my database and found I did not have LO Base on computer any more. Downloaded it and now OK.


The problem is with:

“Description” VARCHAR(16000)

Documentation shows:

Variable-length non-Unicode data with a maximum of 8,000 characters. Firebird can hold up to 32,765 characters. In 6.5, maximum was 255.

I received same error in Firebird embedded & server but all was OK with:

“Description” VARCHAR(8000)


Can’t say where the problem actually lies. Some additional info → tdf#71251

Tried just adding a large Varchar field after table was created and got same error.

The problem lies in there being a fixed maximum of 64K for any insert statement with the current version of Firebird.

A suggested workaround is to change your large varchar field definitions to CLOB fields instead.