LO Draw landscape print crops diagram

I seem to be unable to print (LO Draw 6.3.3) a diagram in landscape mode, even when selecting landscape, per:

  • [Page] [Properties] [Page] [Orientation] : Landscape

The diagram displays as expected in landscape mode, but no matter how I try to print (whatever print driver), I get landscape printed, but the diagram is always cropped on the right side, as if I had been trying to print a landscape diagram with the printer set to portrait (which it was not).

No matter what I do, the right 2.5" of the diagram is always cropped off (prints blank).

I can supply a LO Draw file for testing…

The only work-around that I have found so far is to take a screenshot of the LO Draw app, then crop to the diagram, then scale to print from a graphics app. Voila! I get what I want, but it is a kluge.

This is obviously a bug, that hopefully can be fixed soon. Meanwhile, is there a simpler work-around?


2019-11-27 : additional info as requested:

  • OS: Windows 10 (current updated)
  • diagram: created in LO Draw using
    native LO Draw templates (shapes,
    lines, etc.)
  • file format: since this document in
    LO Draw, it is (obviously) a “.odg”
    file format

Erratum: in spite of not being able to print the full diagram as expected, I did test the LO “Export as PDF” with the resulting exported PDF emerging as expected: landscape, with no image cropping.

I have uploaded a test file, but this portal does not allow me to upload PDF files :expressionless:

Anyway, except for [Export as PDF] … which works as expected, any time I try to print, the print driver automatically defaults to portrait … so it would seem that there is an issue where the LO parsing to the print driver incorrectly tags landscape documents as portrait orientation.

I can, of course, over-ride this by manually changing from “Portrait” or “Automatic” (which defaults to portrait) … but depending on the print driver, either the image is rotated and/or cropped.

For now, it seems I can work-around by exporting first to PDF, then printing from PDF. However, I should be able to print landscape directly from LO Draw, right?

I KN diagram - test landscape printing.odg

I can supply a LO Draw file for testing…

Yes, that would be very helpful.

To upload the file here, please edit your initial question.
Please do not write an answer, if it is not a solution to the actual question. Thank you.

  • Which operating system do you use?
  • Is the diagram a simple picture (jpg) or how did the graphic get into your file?
  • Which file format does your diagram have?


supply a LO Draw file for testing


I found the following:

When I open your file, Slide>Properties... displays Landscape in the menu.

I’ll go to File>Printer Settings...

image description

and then choose Properties. It is displayed in portrait format.

I choose Landscape and OK twice.

I save the file (this saves the Landscape setting for the printer in the document).

From now on, the landscape will be printed even if the file has been closed and reopened.

Here’s a scanned printout of your graphic:

image description

My conclusion:

Set the printer setup to landscape format.

Sorry, for the german UI. Possibly terms may differ.

I hope it helps you. I wish you success!

If my answer has solved your problem, please click on the checkmark in the circle image description to the left of the answer and click on the arrow ^ for upvote. This will tell the community that the question has been answered correctly.

With me Windows 10 Home; Version 1909; 64-Bit | LibreOffice, Version: (x64).

This is an interesting work-around. I will try later to see if it works.

However, this (assuming it works) is, by any stretch of the imagination, a bug work-around.

It should not be necessary to do this and, anyway, this work-around is not obvious or intuitive.

Presumably, the problem lies with how the document is parsed to the print driver. Since the document page format is explicitly set to [Landscape], this is how the document should he interpreted by the print driver.

This is not happening. It seems that it does not matter whether the document is page formatted as [Portrait] or [Landscape], it is interpreted by the print driver as [Portrait], regardless of the specified page format is the source document.

Obviously, there is a glitch somewhere … a glitch that needs to be entered into the bug log for fixing in a future update.

How does this get escalated for attention by the development team?

I do not think it is a mistake, but the normal processing.

If you see it differently, you can write a bug on Bugzilla.

Please announce the link from Bugzilla here.

To do this, edit your initial question. Thank you.

This is a bug, period.

I tried the suggestion of , but with no success. I changed the properties in print setting to Landscape, cancelled the print request; saved the file, then re-opened it. However, when I tried to print, the print tried to (incorrectly) print in portrait mode. If I went back to print properties, I saw the orientation flicker for a moment, before displaying “Automatic” … which, as found before, defaults to portrait, even though the document is clearly page formatted as landscape.

Work-around seems to be to first [export] document to PDF, then to open PDF and print that. But this is a perverse and it should not be necessary to have to go through this, less than intuitive, work-around.

See Bugzilla: