LO takes 1min 15s to start after Windows reboot

Here are the steps:

  • I reboot my windows computer
  • I start LO either by clicking on a writer/calc document or by calling it from the command line
  • LO takes about 1min 15s to start.
  • If I close it and try to restart then LO loads in 2-3s

Here are the solutions I’ve already tried and that didn’t work:

  • disabled network cards
  • turned printer on
  • Changed default printer to system pdf printer
  • Deactivated loading printer setting within the document
  • changed history picklist size from 25 to 2
  • Changed Graphics options in: Tools → Options → LibreOffice → View → Graphics Output unchecked Use anti-aliasing and Use Skia and User hardware acceleration
  • Disabled Java
  • start in safemode --safe-mode and reset to factory settings
  • Disabled OpenGL

My system:

  • OS Name Microsoft Windows 10 Home
  • System Model G3 3579
  • Processor Intel(R) Core™ i7-8750H CPU @ 2.20GHz, 2208 Mhz, 6 Core(s), 12 Logical Processor(s)
  • Installed Physical Memory (RAM) 16.0 GB

My LO version

  • Version: (x64) / LibreOffice Community
  • Build ID: 382eef1f22670f7f4118c8c2dd222ec7ad009daf
  • CPU threads: 12; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
  • Locale: en-US (en_US); UI: en-US
  • Calc: threaded

2 questions from there:

  • what’s the root cause?
  • Is there a way to run LO in verbose mode or other mode that would help me debug?

Thanks for the help!

I’m running a new install (re-installed LO yesterday) so that’s probably not the issue?
I tried to find the repair option in the page you pointed to but couldn’t find it.

Any stray snake oil aka antivirus in use?

1 Like

I uninstalled Avast and turned Windows Virus & Threat Protection off. No improvement. Good idea though.

From the moment I hit Enter on Windows log in till LO (parallel install) Writer is loaded and ready is 56 seconds. Subsequent opening on same session is around 10 seconds.

I can extend the time to load to 1 minute 8 seconds if I create a default template with embed fonts but the difference is not significant.

I think it is normal for first loading to take longer otherwise there would not be the option to set Quick Start on loading OS (load libraries I think) when installing a new version.

Version: (x64) / LibreOffice Community
Build ID: 681d65acd9ede00dd724d6716f21cabfdcc95bd2
CPU threads: 8; OS: Windows 10.0 Build 22621; UI render: default; VCL: win
Locale: en-NZ (en_NZ); UI: en-GB
Calc: CL

Device name LAPTOP
Processor Intel(R) Core™ i7-8550U CPU @ 1.80GHz 1.99 GHz
Installed RAM 8.00 GB (7.88 GB usable)

I just activated Quickstarter and now first open takes 15s. That solved it, thanks @EarnestAl !

1 Like