Mail-merge failing

I’ve been using mail merge in open and libre office for several years now. I recently upgraded to LO running on linux mint 17 64 bit. Mail merge has become very unreliable. Sometimes it works and usually it doesn’t.

I use spreadsheets as the data source. I’ve created database files by opening LO Base, connecting to existing DB, DB type spreadsheet. I have 3 odb files or databases stored in the /home/username/Documents folder.

I have opened a LO writer odt file that has field names for one of these databases. I can press F4 to confirm that writer knows about the database and that the data is present within the database. Hovering over the field names in the writer document shows fields from the database I’m trying to use. When I select File-Print, writer displays the dialog box asking if I want to print a form letter? I select yes and then the Mail Merge dialog box opens. I select the fields I want to include in a printed report (the Records selector changes to indicate Selected Records), press OK and nothing happens. The printer select dialog never opens to select printer and printer options. Nothing happens and nothing prints.

I have also tried going through the same steps but selecting print to a file. That will open a file name dialog - but no output or file is created.

Is there something I can do to get mail merge to work again? Thanks in advance for any advice you can offer!!

Not an answer - but additional info. I just logged out and back in (not a restart - just a log out and in) and the exact same steps, starting with opening a LO writer odt file and everything worked as expected. The printer select dialog box opened and I was able to select printer and options and print the report.

Any ideas what would cause that behavior??

Here is a THREAD which might be relevant (but not necessarily give an answer). And also THIS (rather unsatisfactory) work-around

As in the thread you linked to above - killing LO and restarting restores mail merge to functionality. Not ideal, but at least doable. I only have to run one mail merge every few days so i can do this. Presumably, Logging out and back in as in my comment below accomplished the same thing.