Malayalam CTL font symbols problem when formatting with styles

SampleFile.odt (37.6 KB)

I am using Manjaro 21.2.6 Qonos / LO Ver.

In LO Writer, whichever Unicode Malayalam font is used as CTL Font when formatting using Styles in Libre Office, wherever the symbols (means period / full stop, comma, semicolon, colon etc) appear, they are not of the CTL Malayalam font; but from the corresponding Western Text Font. And there are glyphs for these symbols present in the Malayalam Unicode Font table. This damages the Leading (Leading is the space between multiple lines of type, which can be as few as two lines of type to, well, as many lines as needed). of the paragraph also. The question is how to fix this.
My locale -a output is pasted here.


Edit your question to improve it so that we can understand what is at stake. Mention OS name and LO version.
What is the “symbol”? Is it a full stop? If so, are full stops required by Malayalam grammar to separate sentences? Is there a special Malayalam glyph for full stop? If not, Unicode encoding for FULL STOP is U+002E which effectively falls in the “Western” range. But since the full stop marks the boundary between two sentences, the break in script should not structurally break the layout of the sentences.
So, could you explain to non Malayalam-familiar readers what you expect? You say it “damages leading”. In typography, leading is a visual “guide” (usually made of repeating dots) between some words on one side of a page or column and a corresponding information on the other side (e.g. the dotted line in a TOC between chapter heading and page number).
Your paragraph don’t seem justified either.
The best thing you can do is to attach a sample file. This will facilitate analysis of styles since you seem to blame them.

See also: tdf#148257 (note how it discusses choice of shared glyphs in the three existing sets of fonts (Western, Asian, CTL) in any text run, which is what this question is about).

Thank you @ajlittoz
I have edited my question and uploaded a sample odt file also.

Contrary to your assertion, you don’t use styles. The whole text is manually formatted. However this doesn’t change the problem (but for the fact mentioned in tdf#148257 that once CTL is enabled you can no longer force the language in the style).

I had to enable CTL, so perhaps you didn’t do it on your computer.

Digits: there are indeed specific Malayalam digits starting at U+0D66. It then depends on the input method utility in your Manjaro (not familiar with it, I use Fedora) whether ASCII digits on your keyboard are converted to Malayalam or not.

You can force them anyway in Writer by typing “U+0d66” (without the quotes) immediately followed by Alt+X for zero and other hexadecimal code up to U+0D6F MALAYALAM DIGIT NINE. They are followed by three glyphs for 10, 100 and 1000.

Punctuation: the Malayalam block does not contain specific glyphs for punctuation. You can perhaps “borrow” punctuation in other Brahmic sub-blocks. I found U+0970 DEVANAGARI ABBREVIATION SIGN which is said to be equivalent to full stop. But rules may prohibit to mix Devanâgarî with Malayalam.

Leading issue (line spacing): this is caused by the automatic choice of font in CTL context. The Font dialog allows to “split” the Unicode coverage into Western and CTL contexts. This is configured as Liberation Serif for Western and RIT Rachana for CTL. These fonts have not the same metrics and this causes the irregularity when characters from different blocks are mixed in a paragraph.

This can easily be fixed. Either you set CTL to Liberation Serif too because this font has a very wide coverage, or (because the shape of the glyph is not to your liking), you set Western to RIT Rachana as it is very likely that the font also covers a major part of Latin 1.

Then both languages will be set in the same font, clearing the metrics issue.

One last advice: learn to use styles. This will really ease your work. Read the Writer Guide.

Thank you @ajlittoz
Your reply really helped me to better understand the issue. But I don’t think setting both the CTL and WTF with the same font, fixes the issue, but it is good as a work-around. Thank you very much.