mathtype equation numbers

Hi all,

I am having the following problem: people I work with insist on using ms office and mathtype to write their scientific reports and papers on windows. I however have to use linux (for other programs for my research) and I am using libreoffice (to open their doc and docx files) and latex for my own documents.

Now here is the problem: if they send me a document written with word+mathtype and it has equations with equation numbers, I cannot do the following: see the equation numbers or edit the equations when I open the document in libreoffice on linux. I have tried to open the document in libreoffice on windows with mathtype installed on the machine. The equations will open in mathtype but the equation number still not showing.

Is there a fix for this? Has anyone solved this problem?

I have seen a guy from MathType on this site going on about the how mathtype is the best and all that and how they made some market study and concluded that a linux version would not be very profitable but he is just wrong. Whoever made that study for them should be sacked because they clearly don’t know what people in scientific fields like to use, operating system wise.

I repeat I only need this to be solved because other people insist on using ms office and mathtype and I would rather avoid dual boot or virtual machines just for this.


If you can link to an example file that doesn’t display well in LibreOffice, I would like to play around with it and see if I can find a solution.

here you go:
test file

Interesting. It shows up with equations in LibreOffice 3.4.4 on Mac OS 10.7.4, but there is some extra text also:
Equation Chapter 1 Section 1* MERGEFORMAT ()
The two equations shown are a+b = c and x+y = z.

Were there any other equations that were supposed to show up? (I should think you could live with some extra text, as long as all the equations were there.)

no there were only two in that file. but this is what happens on windows (and now I know on Mac OS) but if you open that on linux you see the same extra text but no way you can edit the equations. is this normal behaviour or are there any tricks to solve the problem on linux?

By the way, I don’t see a way to EDIT the equations, just to view them (on Mac OS X).

Unfortunately I don’t have a way to see the file on Linux to even see if I can figure it out.

There is known limited support for MathType. List of open bugs here. Related question here.

but did you understand my problem? no way to see the equation numbers that were created in windows if you open the document in linux. this is the problem! mathtype is mathtype and they will not change anything, but I guess libreoffice might solve this at some point.