Need help turning off autocorrect in LibreOffice Calc

I am trying to turn off all autocorrect options, and it isn’t working. Let me be clear: I want to turn off ALL autocorrect options, not just some of them. You don’t need a reason from me, I need to know the method. Sorry if I’m coming off snarky, but I have to mention and discuss the various obstacles which have been present in my attempts to do this what should be a simple task.

  • I have looked for options to turn off autocorrect, and I found several. But as autocorrect is still on, I have clearly missed some. I have searched online and found answers, but they have not helped me find the as yet unknown to me autocorrect options which are still on. Please help. Currently I am trying to type -ln56 and it is replacing it with 0. This does not disrupt my workflow, it derails it entirely.

  • There should be one option to turn off all autocorrect, and it should be easy to find. But even if there are multiple options, they should all be found in the same place.

  • Periodic updates should not reset my settings. Every time I update LibreOffice Calc, I have to go through this nonsense of trying to turn off autocorrect, and the settings are different every time. This is an old program; the settings layout should not be changing on a regular basis.

  • Autocorrect should default to off in LibreOffice Calc. This program is more commonly used by coders, programmers, and other data workers who need autocorrect off than it is used by students or laypersons who may or may not want it to be on. Suggested changes should default to on, autocorrect should default to off, and both of these should be easy to change with an easily found single option to control the entirety of either one.

  • Semi-related, but LibreOffice Calc should also default to not re-formatting existing documents, and the options for reformatting or not reformatting should be clear and thorough. What I found instead is that upon opening a document, I am presented with some reformatting options, in which I do not even have the option to preserve existing formatting, but instead must discover (potentially through trial and error) which formatting method matches the existing formatting, so that when LibreOffice Calc inevitably reformats the entire document upon opening it (is that why it takes so long to open a document?), it leaves the document functional rather than rendering it useless and possibly deleting anywhere from minutes to years of work.

  • All of the answers to this question I have been able to find are old and, as mentioned before, the options have changed, so their advice mostly doesn’t work anymore. There should be an easy-to-find answer to this question in the FAQ, that is unless you were to fix the problem so that it didn’t come to this in the first place.

I simply cannot wrap my mind around what could possess a person to think that autocorrect should ever default to on in any scenario, or why it should be made this difficult to turn off, or why it is so uncommon for people to ask this question, given the immense and often insurmountable difficulty present in circumventing this absolutely disruptive and even destructive setting. If it weren’t for the fact that virtually every document editor in existence forces autocorrect on the user, this would simply be a deal-breaker and I would skip out on LibreOffice entirely in favor of an editor which was more user-friendly. Again, please don’t misinterpret me. I’m not trying to sound snarky. Can you see where I’m coming from? I feel as if I’ve been immensely charitable here in keeping my temper in check thus far. The amount of damage caused already is tremendous. Please don’t make it any worse.

It isn’t AutoCorrect, it is a built-in function, see help:

## LN Returns the natural logarithm based on the constant e of a number. The constant e has a value of approximately 2.71828182845904.
You can either format the column as Text or place a space before so you enter “ -ln56

Updates do not change your settings, they remain in your user profile

The last similar statement I saw was that all numbers should default to two decimal places because most people use it for financial calculations. You must make the settings that suit you, other people use it differently.

Consider too, if you are using the right tool for the job. Maybe Base or Writer is better suited to your task.

You might find the the Calc Guide useful, downloadable from English documentation | LibreOffice Documentation - LibreOffice User Guides

2 Likes
  • LN56 is the reference of a cell.
  • In a cell not formatted as Text, if do you type a number or a cell reference after = or + or -, Calc understand that it is a number (dates included), a formula, or a cell reference. This behavior after + and - was introduced a few years ago.
  • So -ln56 gives =-LN56; and if LN56 has no numbers, you will get 0.
  • As a workaround, type ' (apostrophe) followed by -ln56, or format the cell as text.

Maybe, not sure. I’m teaching Calc at the high school.

Are you working with styles? What kind of documents? Please, open a new topic, and share a reduced sample file.

1 Like

When I first opened one of these documents, the default formatting turned all spaces into commas.

And yet both times I have updated LibreOffice Calc, I have had to redo some (but not all) of the settings. For example, the first time, I had to turn auto-comma formatting off again. The second time, I had to turn off spellchecker (even though it was off when I originally installed it). Both times, I had to turn autocorrect off.

First of all:

In Calc, when a cell is formatted as a number, any input is parsed to detect different kinds of numbers and formulas. Any input starting with = or - or + is interpreted as a formula. Using formulas is the intended workflow in spreadsheets, even for “data workers”, and is unrelated to the “autocorrect” which you imagined was your problem (which was not in this case).

However, there is tdf#131638, that unfortunately breaks workflow when you properly pre-format cells as text. This is a bug, which should be fixed indeed - but again, this is unrelated to “autocorrect”.

Now to the rest, which was just untargeted rant.

You seem to imply later than you are one of “coders, programmers, and other data workers”. Please excuse me if I’m a bit snarky, but I find it very strange when someone with such a background hasn’t developed a muscle memory to accompany every keypress that gives “I tried something” with a reference (a link, or at least a description “I tried this, that and that”). Specifically, you could e.g. refer to Calc’s menu Tools|AutoCorrect Options, and Autoinput, and maybe something else, so that others could see what you tried, and not waste time suggesting the same.

As shown above, your specific problem that you described above was not related to autocorrect. This is a perfect case of an XY problem.

Again: please be specific. In LibreOffice Calc 3.3.0, AutoCorrect Options menu was exactly under the same Tools main menu, as in the current 7.3.4. But maybe you refer to something different - which is unspecified? If you mean that the options change their values on upgrades - that would be a bug, which needs to be filed.

I can’t reply better than @EarnestAl. I can only tell that I laughed much, thank you. Also I wanted to mention something called “database” that is more suited for the “store without any processing” than spreadsheets, as well as for the user categories you identified.

LibreOffice is expected to open files as close to original look as possible (modulo bugs and incompatibilities with document models with external file formats). Please consider each case of changed formatting on import as a bug, and report it.

So in the end: there are several different things related to spreadsheets: data recognition (i.e., how to convert a random user input into one of the several Calc data types: text, number, formula), and in that process, maybe also format it (e.g., when a user enters 2022-07-05, they typically expect it to be recognized as a date (a number internally) to allow further calculations like counting days, but they wouldn’t expect it to show as 44747) - which is controlled by cell format taken into account at the moment of data entry; data autocorrection (like automatic replacement of typical typos, or applying bold to *text in asterisks* for users accustomed to markdown; note e.g. that related tdf#133023 was changed to default to inactive yesterday); typing aids like AutoInput; unsupported (yet) features like pivot table formats, dynamic tables from Excel; and bugs. The autocorrect options were gathered in a single place - exactly as you propose; its position hasn’t changed since 2011 (actually even earlier - OOo 1.0.3 from 2002 already had the menu there); AutoInput is put to the same menu in 5.1, and placed next to autocorrect in the menu in 6.3 - just based on the same reasoning as you present; so please clarify your understanding of the basic spreadsheet principles, acknowledge the effort that the community is making to make the program usable, and join the community by providing constructive feedback, and maybe also start improving it yourself - we welcome everyone.

1 Like