No keyboard input after opening password protected file


I have the following problem:
When I open a password protected file in Libreoffice Calc, the file opens but all keyboard input is disabled for all Libreoffice Applications (Writer, etc.) until every instance of Libreoffice is closed.

I already deleted my profile.

The document is not opened in read-only mode.

Version: / LibreOffice Community
Build ID: 40(Build:2)
CPU threads: 12; OS: Linux 5.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Debian package version: 1:7.4.1-2
Calc: threaded

Really nobody?

Only in this document, or in every one password protected?
It was saved as .ods, or .xls(x)?

See Keyboard not working in Calc

Every password protected file, regardless of ods or xlsx.

I already read that post and follow-ups. The conclusion was to start with a clean profile after starting in safe mode. That did not make any differences.

Yes, there was a fair bit to check in that post but it sounds as if you have arrived at the final comment, tdf#149161
You could add yourself to the cc in the bug report, numbers count there more than a me too in the report.

I just solved it:
LibreOffice was using VCL plugin X11 (You can check that with Help->About). Switching to gtk3 by installing the Debian package libreoffice-gtk3 solved the issue.

1 Like