No text or menu items in LO

Installed LibreOffice_5.3.2_Win_x64.msi over LO (Win64) on a Win 7 OS notebook.
New installation runs, but shows no normal text (some rotated text shows), and menu items are replaced with long “dashes” including menu tree items.

The problem does not appear on Win 10 machine.
I have noted and appreciate the advice, will revert to LO 5.2.4, and await the next upgrade. Will close the Question.

See this article

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

Thank you David.
I have been patient with this issue, and have tried LO5.3.3, 5.3.4, an 5.4.0 both as 64 and 32 bit code. I have tried to completely remove LO (and user interface) and re install the newer versions but without success. I have reverted to LO 5.2.7.
I have followed the discussion for Bug 107166 and added to the issue (Bug: 111391 with my Screen shots).
I am concerned that the issue appears to be “Resolved!!??”