Not printing one line in Draw

I use LibreOffice draw to make our personal greeting cards. For some reason, it will not print the top line. If I re-type it in the second line, then go back and delete the first line, it still won’t print. This is strange. I am hoping to be able to attach one on which it will not print the first line of the inside or the line on the back saying “made especially…” Any help would be appreciated! Is there a way to attach a file? I will try to explain a bit further…one the inside of the card, I type in a box and then flip it so it is upside down. That is where I seem to lose the first line printing no matter how the box is oriented. Hope this explains it since I can’t attach one.

If you can edit your original question by clicking the pencil icon then you can add a Draw file by clicking the up-pointing arrow with tooltip Upload. Otherwise click the speech bubble at the bottom of my comment to add a new comment on which you can upload your file.

Note that sometimes printers have a larger margin at the bottom of the page that at the top

It says max upload 4 MB so I deleted the first page which isn’t an issue and it is now 2.6 but when I go to upload, it still says max upload 4MB? I understand the page margins and printers–that’s not it. Seems to be an issue with flipping the text box so it prints correctly on the card stock?

1 Like

It’s an .odg file?
Can you print a rectangle (shape) in the place of the top text line? Or a part of the shape also wouldn’t print?
If you can’t upload the sample file, at least share a screenshot of the whole page to understand a bit more. Thanks.

I will try with adding a shape. I could not upload but attached to an email response to EarnestAl so maybe he can upload it. A screenshot won’t help because it looks fine; it just doesn’t print fine? I’ll be off for a while but will try your suggestion and post early next week.

Why not use a file hoster or share on some cloud (e.g. google) which are free up to a dedicated limit?

Sorry, I did not receive an email nor an attachment. There is no private message either.

You could try removing images, or replacing them with low resolution images that don’t affect the problem because it is only the problem we are interested in. Just make sure the problem still exists in the modified file

1 Like

Card.pdf (105.5 KB)

See if these upload. card1 and card 2 are screenshots from the .odg file. You will see on the one side under the little pic it has “made especially for you by DJ.” The other side has 8 lines of text which is in a text box. On the card.pdf; that is a poor scan of what actually printed but think you can see that the first line of text is missing on one side and the “made esp…” is missing on the other. This is very perplexing…

You have MacOS and Envy printer? Try the accepted answer on HP site Solved: HP Envy 4500 Margins Too Big - HP Support Community - 6296867

If you delete the images and Save As [another name.odg] can you upload the file?

Try the answer above first though

And please copy the information from Help > About LibreOffice by clicking icon next to Version Information.

Without images, it is 2.6 MB, but still says it is too large. I have another “clue,” however, I deleted the inside picture completely (instead of just moving it from the print area) and then the inside printed properly. It is definitely something printer-related, however. I printed it two-sided on a b/w copier on my home network and it printed out fine. I will look again at the “Solved” one you posted because my first look/trying their suggestions did not work. Thank you all for trying anyway! Just noticed the popup is in the screenshot; I think the info you want is above it thought.

[Made image inline - EarnestAl]

Without images it should be a few Kb.

  • Save As [a different name].odg
  • click on each image (even ones off the page, they still count in file size) and delete it.
  • Save and see if issue exists, if it does upload [a different name].odg here, it should be only 15Kb or so

Half is underneath the tooltip. Please click the icon and then paste the text into a comment

I’ll try now; I printed as attached without any images; still cuts off first line inside. I don’t know why it saved much smaller–no pics were in the doc I used the last time trying to upload; however, when I saved under another name, it worked? Weird…maybe memory… Anyway, any clues on why it won’t print the first line inside would be a tremendous help.

Retirement No Pic.odg (20.3 KB)

The document prints fine for me on Windows.

  • I don’t see Skia or Vulkan in your User interface so that remove some potential issues
  • I don’t have Dickens Carol font but Britannic Bold is a Microsoft font that presumably comes with Windows or MS Office and I do have that. No issues
  • From what I see, this should affect every Mac user if it were a LibreOffice bug but I don’t see anyone else raising the issue. I think it is an issue in your computer.

Did you reset the print system as linked in a previous comment? You should do it now, here is the Apple link, Reset the printing system on your Mac to solve a problem – Apple Support (UK)

If the above reset of print system doesn’t fix the problem then you should report it as a bug, How to Report Bugs in LibreOffice - The Document Foundation Wiki

Other stuff

  • The second page does not need to be upside down, set the HP ENVY Pro 6400 printer to flip on short edge
  • When you add an image, either drag it from a file manager or use the Insert > Image menu. This will keep the image in its original format which will typically be much smaller than pasting an image from another program. If you are getting the picture from an internet site, download the image first to a folder, then drag or insert it from there. If you paste an image then LibreOffice will save it in the document in a lossless .png format which is likely to increase file size substantially compared to jpg

Cheers, Al

I sure appreciate your time on this, it’s very frustrating. So, I reset the printers (though did that previously); I printed it on short edge and now it printed the picture with it. Changed the print style of “made especially…” to Arial–still did not print that line or the first line of text inside. I tried printing on the copier (no color there) and, despite it printing correctly previously on the copier, NOW it prints the same as the HP–ignoring the “Made especially…” and first line inside text. I do think it is something within communication between LibreOfficeDraw and the Mac but haven’t been able to figure it out. How would I file a bug report? Again, appreciated your time.

Here is an unrelated issue on HP web site but the answer is apparently unrelated to the question; it might be worth checking, Solved: HP Envy Pro 6400 won't print in color from Mac - HP Support Community - 8037806

PS how to report bugs is linked in my previous comment

:frowning: Sorry, missed that–I won’t report a bug however. Not sure how to word it and, to be honest, not sure it is truly a bug, especially after reading the info on the link you sent! That’s the printer I use but have not had any issues except for this one. Still points to potential for printer communication as opposed to a bug. Thanks for your help–truly appreciated!

Could it be that the frame is rotated 180.59 degrees?

Test with this file: Retirement No Pic LeroyG.odg (17.7 KB)
I adjunted the rotation angle to 180°, and reduced the frame size.

Appreciated the effort, but it still took off the first line inside–appears on screen, not printed. Funny, I copied and pasted the first line, printed and it was fine but on screen, the line was there twice :slight_smile: ? Weird…

Because I am a bit perplexed by this, I took the actual document as done, sent to my Windows computer, opened it with OpenOffice (don’t have LibreOffice there but they appear similar), made no changes, sent to the Envy and it printed out perfect. So, it must be something between Apple, LibreOffice and the Envy. For now, this topic is closed as I will just send to the other computer to print but thought I should pass this on.