On mac catalina I can't save my work

I have Catalina installed on my mac and I can’t save any of my work.

When I click on save, save as, export, etc. nothing happens. I get the spinning wheel and it just stops after 10 or 15 secons. No popups, nothing.
I installed the previous version of libreoffice and have the same results.

I also tried changing the mac security settings to allow libreoffice to change my mac. That didn’t work either.
I even tried to save it on a One Drive and also with SSH, neither of those worked.


please see my answer in the following question: https://ask.libreoffice.org/t/unable-to-save-or-save-as-any-document-even-in-safe-mode/53456 The key to success is to provide LibreOffice.app Full Disk Access (How to - see link)

There are also comments in bug reports which propose the following solution (which I could not test yet):

  • Open terminal program console
  • Change the directory to the app folder: cd /Applications)
  • Execute: codesign -vvv --deep --strict LibreOffice.app

Hope that help.