On Mac: LibreOffice keeps crashing

Did you check the

System Requirements.

Installation Instructions

First steps


Thank you. I’ve checked the System Requirements again, and I think everything should be OK (except perhaps the last point?):

  • macOS 10.12 or newer
    • running macOS 12.3 now
  • Intel or Apple silicon processor (via Rosetta - native Apple silicon support is being developed)
    • 3.1 GHz Dual-Core Intel Core i7
  • 512 MB RAM
    • 16 GB 1867 MHz DDR3
  • Up to 800 MB available hard disk space
    • 577.88 GB available of 1 TB
  • 1024x768 graphic device with 256 colors (higher resolution recommended)
    • Don’t know; what I can find is “Intel Iris Graphics 6100 1536 MB”

Also, I’ve updated Java and am now running Java SE Development Kit 17.0.2:

I’ll now again reset the user profile, restart in safe mode, etc. (see original post) to see whether there is an improvement.

The crashing continues, so I’ve created a bug report tdf#148051 , frankly not knowing what else to do.


The TDF Wiki describes that a parallel installation of different versions of LibreOffice is basically possible. The procedure differs depending on the operating system and for Linux also depending on the package system. Did you follow the instructions for a parallel installation of different versions of LibreOffice under macOS?

:link: Installing several versions of LibreOffice in parallel on macOS


Thank you for the link! I’m afraid I hadn’t followed these instructions for installing multiple versions. So what I’ll do now is uninstall all LO versions and then do a fresh install of the latest one, and see whether things improve.

I’ve now uninstalled all LO versions from my computer by going to Finder → Applications, and I also deleted the folders under Library/Application Support (to make sure no user profile survives), restarted the computer, and installed LO, so this is the only version of LO running.

I renamed the app “LibreOffice_7313.app”, started LO and did some minimal changes in the Preferences:

  • Advanced: Java Options > 17.0.2
  • Language Settings, Writing Aids: all Options off
  • Writer:
    • Auto Correct Options: turn off ALL
    • View: Formatting marks on
    • User Interface: Tabbed compact

I then quit LO, restarted it again, created a Writer document, and started writing (quickly). The spinning wheel occurred and I had to force quit.

I have saved the report.

For what it is worth, I have no issues with 7.2.5 on Catalina with a MacBook Air, but it doesn’t see very heavy use, either.

1 Like

I’m not sure if it’s wise to rename the app if there is only one LibreOffice installation on the machine at the time of renaming. It might have been better if you had first tested the new installation as shipped from TDF.

The article I linked above describes two procedures, the Old Method and the New Method. If I understood you correctly, you used the old method. The old method does not seem to work for LibreOffice versions 3.4.x and later. The new method involves setting up a so-called Start Script to easily use a different user profile directory for each version of LibreOffice.

Good idea to leave the app name unchanged. So I again fully deleted LO and reinstalled it, not changing the name this time. After working in a Writer document, while doing some Find & Replace, LO crashed again within less than ten minutes. So the file name of the app does not seem to be at the root of the problem.
As for the method I used to run parallel versions of LO, I must confess using the Start Script is beyond my capabilites. But as it has now turned out, LO crashes even if there are no multiple versions running.

I noticed that in the English and German language forum of Ask LibreOffice, several macOS Monterey users report unexplained program crashes. Perhaps this misbehavior is simply due to one or more of the notorious peculiarities of macOS Monterey in interaction with LibreOffice. Since I, unfortunately or fortunately, depending on your point of view, still use macOS Catalina for hardware-related reasons, I can neither verify nor confirm these reports. However, it could well be that you as a user can do little more than wait for Apple to fix the corresponding underlying bugs.

1 Like

I don’t know Macs–at all–and I can no more read black print on a white background in terminal than a frog can see a fly that isn’t moving :slight_smile:, but if you open a terminal session and launch LO using open Libreoffice.app or whatever, will you see error messages in terminal?

No, if I open LO from the Terminal, LO opens (without error message).

But if, after a crash, I open LO the normal way, an error report (or crash report) is generated. I have uploaded one of these here: https://bug-attachments.documentfoundation.org/attachment.cgi?id=178950

I have the exact same issue as jeshkol on Mac, tried all the fixes he suggests, nothing has worked just like for him, it has made libreoffice unusable for me, without a doubt in my view was triggered by the last few monterey updates

1 Like

Please add your voice here: #148051#c9

hello, fyi, i reverted back to version over the past 10 days or so and have not experienced any crashes, however that version seems to have an issue with JRE and I cannot assign macros to shortcuts

fyi, so in a foolish burst of optimism, I upgraded to LO 7.3.2
I opened a blank spreadsheet, filled it with random numbers and as soon as I tried to do one copy-paste, the spinning wheel appeared and it has since been hung for 20mn… so issue is still there, for what it’s worth, though I cannot demonstrate it factually, it seems to me that 90%+ of the time, the wheel pops when I try a cut/copy-paste (ctrl-C/X-Ctrl-V)

1 Like

Sadly, this sounds so familiar to me.

hello, fyi - i reverted back to version about 3 weeks ago, and I have experienced zero issues since, no crashes whatsoever

I have the crash problem too. I think the problem is related to vertical scroll. If I do a quick vertical scroll using the mouse, Writer crashes. But if I do a vertical scroll using keyboard shortcuts like Cmd+arrows or Alt+arrows, all works fine.

I verified the problem using 7.3.* and with macOS Monterey 12.5.1 and macOS Ventura beta 22A5321D.

I’ve been using LO for some months now (on a daily basis), and there are hardly any crashes/freezings at all anymore – LibreOffice works impeccably on my Mac.

But as soon as I use a version newer than on macOS Monterey, the crashes/freezings reoccur.