Opening the "Edit Style" menu crashes LibreOffice Writer on Windows

I'm using LibreOffice Writer 7.4.1 on Windows 11 22H2. Whenever I attempt to open the "Edit Style" menu, the program hangs and I have to force close it. This only occurs on my laptop. On my desktop it works fine, so I'm not sure what the issue is.

Has anyone else experienced this? Should I file a bug report? Are there any logs I could check that may help me figure out what is going on?

If it crashes on your laptop and works fine on your desktop, it can’t be a bug in the software. In that case, it would crash everywhere. So it must be something on your laptop. For the most likely suspect, see LibreOffice user profile - The Document Foundation Wiki for help.
Please note that is the most recent version, probably packed with new bugs. If you use LO for your work and don’t need the newest features etc., it’s safer to use a “still” version, that’d be 7.3.6.

It might be a graphics issue. Before resetting your user profile, try this. Click Tools - Options - LibreOffice - View and untick the box that is labeled Use Skia for all rendering.

Here is list of checks, some of which might apply, First steps to take before submitting a bug - The Document Foundation Wiki

Cheers, Al

There is such a thing as a hardware specific bug. Not every bug affects every user. :wink:

I have tried both the latest and still versions and both have this issue. Running in safe mode with a fresh profile also has no effect.

Disabling Skia and upgrading my graphics drivers also did not fix the problem, unfortunately. As for fonts, both my laptop and desktop should have all of the same fonts installed so I don't think that is the issue.

Okay, my first shot was too easy. :thinking: If it’s hardware specific, you need to give some information about your hardware. If you intend to file a bug report, remember that the developers will have to be able to reproduce the problem, or they won’t even start trying to fix it.

You could try re-enabling Skia and ticking the box Force Skia for all rendering .

Does it crash in safe mode? Click Help - Restart in safe mode - Continue in safe mode

Well, I’m facing exactly the same issue. I tried various versions 7.x / 24.x / 32-bit / 64-bit. It happens on both my laptops: HP (win7 4GB ram) and DELL (win10 8GB ram).
As it has been mentioned, style window opens in more than 30mins. During that time LO Writer is frozen.
It seems to be not rare issue, so if LO want to be serious SW, it should be fixed! Otherwise it is really unusable!

I just found that, if the screen or computer goes to sleep mode and back to wake-up, window opens immediatelly after wake-up. So recovery from frozen state seem not be time related, but sleep-wakeup related.

Edit 2:
If I run windows in safe mode, it works properly. Safe mode of LO does not help.

Edit 3:
If I kill svchost.exe belonging to following services, Writer works well. It is not enough to stop these services, I need to kill its svchost.exe

Edit 4 (heureka):
Stopping of lmhosts service helps and everything works well… Now question: Why lmhosts service is causing LO freezing??

I would be inclined to do an internet search on something like “windows 7 not working properly after sleep”.
There seem to be many problems with Windows 7 sleep

…or other workaround. We can disable “microsoft network client” on active network interface to make LibreOffice not freezing.
It is only workaroud. LO, please fix it.

It sounds like a Windows error. Maybe some of the suggestions here might help, Redirecting

A minidump could be useful in a bug report. My initial idea would be that there is an unavailable network printer configured somewhere in your system, and the LAN Manager is slow to discover its unavailability. (A printer lookup is unfortunate, but it’s unclear at this point, how to avoid that in our code.)

Aaaaaah… Finaly someone using his brain… :slight_smile:
Yes, I confirm the switched-off shared printer on windows network is causing LO hangs. I set PDF printer as a default to avoid hangs and I will select physical one only when it is on and I need to print.
Thank you very, very much for kicking me up… :wink:

I have (sort of) figured this out. I tried opening the dialog and the program froze up like it normally does, but I had to step away for a while. I was probably gone for at least 15 minutes, but when I came back the dialog was open. Now it seems to be opening quicker, so I'm not sure what was happening but it seems fixed now. Not exactly the most useful solution, but if anyone else is having a similar problem try just letting it run for a while.

Thanks to everyone who responded trying to help!

Did Windows 22H2 come out on October 1st 2022?
It is a major update; with those big ones, after the computer has rebooted I wait for 5 or ten minutes and then Restart the computer as there are often supplementary updates that are installed after the main update. Windows tends to behave oddly if it has updated and not restarted. That might have been a symptom