Password incorrect with .xlsx file & .ods file

Hi guys I posted about this same problem back in January 2020 and received some helpful advice at the time.
I have only now just had cause to try and access those same files from Jan 2020 but I am getting the ‘Incorrect password’ message each time I try and unlock the file(s) both in .xlsx and .ods versions.
The files are on the same USB stick and I am using Windows 10 up to date on an HP laptop.

I know the password and I have tried using all the 17 characters and then tried only 16, 15, 14 & 13 characters of this password to no avail following on from the advice I received last time re the “truncating password characters”.
See here: Password incorrect with .xlsx file

I am using version Version: (x64)
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win

Does anyone have any guidance for me as how to solve this annoying problem because I really need to access these files?
Thank you for any assistance that may be forthcoming.

Guys I will cancel this Question as I have discovered the problem was that a “0” had been entered as “O”.
Thankfully it was just a simple human error problem (mine) and not a bug or corruption of any type.

Great to hear! :slight_smile: