Password incorrect with .xlsx file

Hi guys
I “Saved as” an .xlsx file now I cannot open it as it says “incorrect password”. File is stored on a USB.
i have the password written down in front of me but it will not accept it and I have tried maybe a 100 different passwords based on the written one. If I had made a mistake in setting the password even with wrong case I would have had to make the exact same mistake twice to set it which is not impossible but highly unlikely.
I have no other copies and it was days of work.
Is it at all possible to access an earlier version of the document that might have been saved/autosaved PRIOR to the Save as with the 15 digit password?
If not what else is worth trying?
I am using Libre Office Calc
Could it be a bug in this new version corrupting the password??
Thank you in hope.

Please try to shorten your password you enter, by one, two, … characters (i.e., drop last characters in your password). There was tdf#97086 (fixed in upcoming 6.4) that silently truncated password to 15 characters when set to XLSX, but didn’t truncate on unlock, which could result in what you see (although you mention 15 digits, which should theoretically be fine, but still…).

Mike you are so right!
You have saved me from having to redo ALL that work.
So just to clear this up I should add this.
When I made the original post I was away from where I had the password recorded so took a guestimate at the number of digits in the password from memory and posted 15 not thinking that this number of digits was at all important in the scheme of things.
So when you posted your helpful advice and I rechecked the total digits I counted 17.
So following your advice I dropped the last 2 digits of the password inputting only the first 15 and hey presto it opened, just like magic.
Glad to see it is being addressed in 6.4 as it was a truly frustrating experience inputting what I knew to be the correct password that was written down in front of me yet the ‘Incorrect password’ message kept popping up.
Once again a huge thank you Mike.

i’d suggest to change question title to ‘password problem with *.xlsx file [solved]’

FTR: The problem was tdf#97086, when a password longer than 15 characters was silently truncated by LibreOffice when set (so only 15 first characters were used for encryption), while all entered password characters were used for decryption, resulting in password mismatch.

The problem is solved in version 6.4, where the 15-character password limit for OOXML (DOCX, XLSX, etc.) is removed, so all characters will be considered in the password for encryption.