PDF content have caracters special different to origin document


I have libreoffice6 installed and running soffice, into RHEL 7, and JBoss eap 6.4, in this a application that call jodconverter framework to conver rtf to pdf document.

I see thath the characters special sach as (accent mark, ñ, etc.) thath containt rtf document, to converter to pdf don´t show that origin, and replace to character �

I have configure into RHEL the file /etc/locale.con from LANG=“en_US.UTF-8” to LANG=“es_EC.UTF-8” and it have same result.

Help me, what can I do so that the conversion is the same as the original document, and does not replace the special characters.


Read these guidelines and ask good questions. In particular, explain the procedure that you use for conversion.

I do not think this is a LibreOffice problem, but one of setup. Check the character set definition for the input file.

The � is the Unicode for an invalid character. (U+fffd). LibreOffice is displaying this character correctly. You usually see this character when converting via a program that does not understand Unicode or you have defined the character set used to one that does not support Unicode. The .rtf document is a text file and does not itself define the character used in the document. For example, if you state the character set is US-ASCII, this will not understand ñ.

Hope this gives a pointer…

I have solved the problem using the libreoffice ( that comes in dvd installation of centos 7.4, which looks like the original with accents and ñ;

Thanks for the help…