PLS HELP! My slides are all white!

Hello, I was making a slide for my presentation but suddenly, all the slides in normal view and notes view are just blank.
I am still able to see the slides in the preview but I can’t click on anything in the normal view.
It’s not just a visual bug because I can’t select anything.
And the weirdest part is that I can still present my slides but I just can’t edit anything in the current one! please help!

EDIT: Here is the link to the presentation. I had to upload it to google drive because it was big from embedded fonts. link:

Can you please upload your file here? Edit your initial question and use the attachment icon.

@Hrbrgr Hello. I tried to upload my presentation but I was told it’s too big. Fonts are embedded into the presentation in order to preserve font spacing when I port the slides from linux to mac.

Are there any other ways to attach my presentation?

Download it to a cloud and post the link here.

Otherwise try the following: Put a copy of your file. Delete all pages except one. Is the error still present?
Then upload the abridged file here (hopefully not too big).

@Hrbrgr I have uploaded it to google drive. Anyone with a link should be able to see / download the file. Also, deleting slides didn’t help much because Japanse fonts are really big anyway.

I have tested it. There is only a white area in the middle. It does not seem to be a slide, as there is no edge. I reduced the file to a slide. The error is still there. I looked at all the settings and could not see a problem. Every other presentation works normally. It seems to hang together with the presentation itself. Unfortunately I can not say why.

When did the mistake start? With which new slide?

With me Windows 10 Home; Version 1903; 64-Bit | LibreOffice, Version: (x64).

Get the repaired file from

Please tell me, when you have downloaded the file, so that I can delete it.

The error was, that in the layer set in settings.xml all layers where set to display=“none”. I have removed these attributes.

It would be interesting, whether you have worked on the file with a different application than LibreOffice, or whether you have done something with layers, perhaps by a macro?

[Edit 2020-01-04] I have removed the repaired presentation in the meantime. The bug report has a macro attached to repair such documents. As always, be cautious and use the macro on a copy of your document.

It is still no scenario known, which produces such documents. Therefore a “fix” in LibreOffice itself is not possible.

Thank you. I will try that as soon as I get back to my work computer.
Actually, it broke after I re-opened libreoffice and “recovered” my file. I think that recovery tool has some bugs. I should have just used my last save.

I should have just used my last save.

And it would have been better in your question to provide all the relevant information.

I am also having the same issue. Could you please tell me how you solved it?

I can tell, what the error in the attached file was. But what makes you think, that your problem is the same?

The document is a zip-container. When you open the container, e.g. by 7zip, you see a file ‘styles.xml’. Open this file in a text editor. Look for a tag draw:layer-set. The child elements should not have any attributes. Something like <draw:layer draw:name=“layout” draw:display=“printer”/> is wrong. It should be <draw:layer draw:name=“layout” />. Remove the attribute and save the file.

If you do not use 7zip but a different packer, you might need to really unpack the presentation. In that case you get a folder. When you repack the files, be careful, that you only pack the content of the folder, not the folder itself.

Thank you. The link by Regina required permissions to use so I simply uploaded and opened the presentation in Google Slides. Google Slides opened my slides correctly. I then was able to download a copy from Google Slides which opened in Libreoffice.

I had been using Libreoffice 6.2 on Linux. I’ve since updated to 6.3 and hopefully the problem never appears again.

Editing the xlm was over my head. Here’s the relevant section from my xml.

You would have to delete all draw:display="none" in that text.

Regina, thank you, thank you, THANK YOU very much! I was about to lose my mind, thinking I had lost all of my work, trying a bunch of things, but your tip was phantastic! You certainly know your stuff!

I am having this same problem! I can’t make heads or tails of the solution here, not knowing what the intricacies of the file format of the slide show might be, or how someone would be able to access in inner code. If it happened to two of us, it could happen to more of us!! Please give me a little more info on how to go about looking into this and constructing a macro to munch through more than 250 slides, which are all blank in the editor at the moment! They will display as a slide show, but I am unable to go in and make corrections or additions!

Am I correct in reading that the origin of the problem may be in the “restore” function that so often pops up if my laptop decides to reboot when I close it up - which it does from time to time. Probably when windows wants to force an update!

Dave Lea - Fish Creek, WI

I just posted my dilemma in a post entitled “Slides are not showing up in Edit screen!” This has much more information on the nature of my problem and the equipment I am using.


Please do not use an Answer for this. It should be a comment. Also, there already is a macro presented in the linked bug report in the answer by Regina - look in comment 6 attachment.

Sorry, Mr. Ratslinger! I am pretty new to this board - didn’t even see the comment option. I would need a lot of tutoring to fiddle with a macro. I have done some coding, but very, very amateur stuff. Most of that was on the 1986 Apple GS Woz machine. Any guidelines readily available here for us septuagenarians??

Thanks a M for your help!! Heck make that a G!

Will be answering in your original post.

Hello, as I opened 3 powerpoint presentation from my old files and trying to make a new impress presentation, all of them got shut down. After I revocered them, the impress file became all blank. I realized what happened after I read this thread, but I had never taken any coputer class and I have no idea where to find the place so I can fix it. Pleas help, thank you very much. Also, I live in Taiwan, so I might appear to be posting in odd hours and might reply after a long time after you post.