Possible force a NewLine Before H2 and H3?

I have a Master-Sub document with H1, H2 and H3 headings in the chapters. I would like to ensure that a new (empty) line appears before each heading, or that it has the spacing height before and after just as is allowed with paragraph formatting.

Is that possible, and if so, how?

Thank you,

Are you the one who deleted your other question? It disappeared between the time I saw it in the home page and the time I finished to answer it. If I remember correctly, it was about bad alignment in headers and my answer was quite detailed.

No, I am not. I added a comment asking why it was marked as deleted. Your answer was detailed, and I am going back to it as my ability to absorb detail is struggling. However, I have already started using this answer, and if I can get back into the other question again (from the link in the email) I will start practicing to understand your answer there. Don’t know how to delete questions, and did not go back into until I received your answer.

I went into the post to start practicing on your suggestions and noted that the comment under the question had a link in it that led to How do I get out of the situation where "Normal" view is book format?. Possible someone deleted it by accident, or was trying to get traffic to that question?

Another comment it seems. Your answer at 299962/headers-not-aligning-properly worked (as your answers always do) and I was able to upvote it. Thanks.

When I try to access the link, I get “Sorry, content no longer available”. The question and its answer is still considered deleted. I don’t know whom to contact to solve the issue.

Anyway, you’re welcome.

Every paragraph style has provision for extra space above and below its context. This is set in the Indents & Spacing of the style definition.

  • Display the style side pane with F11 or Styles>Manage Styles
  • Right-click on the relevant style name (Heading n in your case) and Modify
  • Go to Indents & Spacing tab and change the values in the Spacing section to your liking

In case your headings are at top of page, you may want or not to have the spacing. This is configured in Tools>Options, LibreOffice Writer>Compatibility, Add paragraph and table spacing at tops of pages check box

I recommend you read the chapters about styles in the Writer Guide.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.