Printer won't print in black in Linux

  • I’m using LibreOffice in openSuse Tumbleweed (Linux) and it won’t print the text nor other parts in black

  • I often stay up-to-date with the latest versions from the system and applications which obviously update:
    automatically :slight_smile:

Build ID: 00(Build:1)
CPU threads: 4; OS: Linux 5.9; UI render: default; VCL: kf5
Locale: en-GB (en_GB.UTF-8); UI: en-GB
Calc: threaded

  • I’ve put in brand new Canon BCI-24 Colour & BCI-24 Black ink

  • I’m trying to print a mostly word document with LibreWriter

  • Images and texts do print in colour but they don’t print the necessary black parts

  • I’ve also tried checking the setting ‘Print text in Black’ but that doesn’t help either

  • I’ve also tried to print via the native text editor, so it’s not printing the text via that as well

  • I did do a maintenance check with the printer from the OS and the Printer itself and it’s seem to print fine with all colours though I can’t say for sure whether the blacks fully show. It sort of shows it in the darkest and or lightest of greys, so not fully black but does sort of come across as black so I can’t tell for sure.

  • I’ve checked the internet and on ask.libreoffice and I’ve noticed that a lot of people for couple of years and even recently have been facing the exact/similar issues but no proper fix/resolve to the issue. So hopefully considering I’m the clearest considering the guidelines and very specific concerning the issue, perhaps it can be seen to more hastily.

I’ve found these similar issues but it’s not seen to yet; I’m presuming because the users weren’t very clear as to the specification regarding their issue, so perhaps they can all be closed at the same time once my issue is solved:

[Edit Opaque - Moved from answer to Details, since it isn’t an answer to the question but adds additional details]

Thanks for reading. Hopefully someone finally has a sound answer and fix :slight_smile:

clarification of the matter once and for all.

The printer I’m using is a Canon i470D. As for the driver part, I haven’t installed any kind of driver/s for the printer itself. This is the first time I’ve tried to use a printer on Linux, so I’ve never really tried it before.

I powered and plugged-in the printer via wall socket and USB and I noticed that the printer model seemed to be recognised automatically under “Printer: configure your printers” and “YaST Printer”. It does also present the actual printer in Libre.

I did notice that under configuration it says:

Driver: Current - Canon i470D - CUPS+Gutenprint v5.2.15

If it’s any further help under General it says:

Color Model: RGB Color

and under Priter Features Common, it says:

Ink Type: CMYK Color

I appreciate your input :slight_smile:

I’ve also tried to print via the native text editor, so it’s not printing the text via that as well

This means that the problem is with your printer setup / printer driver and not with LibreOffice. Don’t waste your time checking LibreOffice settings before you get a plain text file correctly printing black colored text.

Please provide your printer type and model and information which driver you are using ("*BCI-24*" is an ink cartridge identifier and not a Canon printer model).

clarification of the matter once and for all.

For sure your target is well-intentioned - but hopeless due to the huge numbers of printers available on the market and the myriads of possible setting configuration combinations. Being for decades in IT, printing has been an issue all the time.