Printing problems LibreOffice 3.6. Few rows don't print properly

Hi, I’ve some rows that don’t get printed properly with LibreOffice Writer (looks like when you have a printer nozzle problem with some lines not getting enough ink or not getting ink at all).
Thing is when I print a jpeg (a screenshot of the same document) from a browser, the document is properly printed. As I realized that, I’ve installed Abiword and tried the same document, which get printed properly, without any problem.

The problem seems to be between LibreOffice and Cups. It looks like LibreOffice is somehow overriding Cups settings.
I’ve tried all the different possibilities from LibreOffice printer administration (PostScript driver, level 1… pdf/8bit…) to no avail.

I would like to know if there is a way to set LibreOffice to change this behavior
(like not using the LibreOffice printer administration tool at all).

By the way, I’ve tried with OpenOffice and the same problem arises.

I’m using an All-in-One Epson Printer (PM-T960) with an epson-inkjet-printer-escpr_1.2.2 driver for linux(debian) from the vendor.

Thanks a lot.

Hi, thanks a lot for your answer. I have prepared a set of relevant documents regarding this issue. Where do you think I should report it? In the bug section of LibreOffice?

By the way, printing from .pdf does not work as well, I have tried with evince and epdfviewer and got the same not correct output.

How to report a bug:

Does the PDF show up correctly on the screen? If yes, then the problem is with your printing driver (or maybe the printer itself). In this case there is no point in reporting it against libreoffice.

I voted your answer up so you have enough karma to attach your example files here. PDF and photo of printed result would do fine.

The easiest workaround to all printing problems is exporting to PDF first (see file menu) and printing from your favourite PDF reader. This has benefit of having “true” printing preview as well.

That said, it would be good if you could report this bug and provide any information and example files, photos and stuff that seems relevant. And then please answer any question that might come up.

Maybe the most first thing to attach is file of postscript output from LibreOffice and a scan or photo of the result from the printer.

Thanks for your answer. I’ve attached the files:
Abiword_print.jpg is the document printed with Abiword;
LibO_print.jpg is the document printed with LibreOffice;
pdf_print.jpg is the document printed with Evince.
Then LibO_postscript_driver.jpg is the document printed with LibreOffice choosing “Postscript(level from driver)” from the language type option (the regular setting is “Pdf”).
Finally, LibO_postscript_driver_dot_ps_file.odt is the postscript file of the document.

Pdfs are showing up properly under all the pdf viewer I installed.

As you are telling that it might be a printer or driver problem, and considering the fact that it prints properly under Abiword or some jpeg from a browser, do you think it’s possible that the pdf part of the driver is, somehow, not written properly?

Thanks a lot.


There is nothing obviously wrong with the PostScript code. Is it possible that your printer is running out of ink or cartridge is blocked? Was the Abiword version printed first and possibly the situation got worse after that? (just trying to be as sure as possible that any simple reason is ruled out)

No problem. Really thanks for all your comments. I printed the Abiword and other files few times to be sure. I guess I’ll give up and buy another printer from another brand in the future. Should I write [Solved] somewhere in the thread or giving up is not really a [Solved] status?

To mark the answer which solves your question click on the gray checkbox on the left of it.

BTW, I myself use the exporting to and printing from PDF all the time, I would export anyway to check if the output is correct without wasting any paper, and I often find things I want to change.

To be honest, that’s what I was doing before. I was using Adobe pdf viewer at that time. The problem was it took a long time to print and the result was not correct at times. Trying few different things, I discovered that printing directly from the wordpro (I was using OO at that time) resulted in a fast and correct printing. That’s why I started printing directly from the wordpro. Aah, if I didn’t lost that old driver, maybe I wouldn’t have any problem now…Anyway thanks a lot for everything.

Is this your printer?

That’s the beast :“
Before, the vendor’s subcontractor ( used to make drivers for the whole range of printers. They stopped and transferred everything to the vendor’s site.
I’ll try to install the windows driver on a virtual XP and report the results.