Problem installing v4.0 on RHEL 6.3 x64

I’m running RHEL 6.3 x64, GnomeDesktop 2.30.2. Trying to install v4.0. Following the “Get Help” Linux install instructions on the website. I got all the RPMs to install using command: yum install *.rpm

I’m at the point of installing freedesktop-menus. Using the command:
yum install desktop-integration/libreoffice4.0-freedesktop-menus-4.0.0-103.noarch.rpm

Yum exits and reports “Error: Nothing to do”.

I have no icons in Gnome menus. Anyone have any pointers?

Answers to qubit’s questions:

  1. Yes, my question was very similar to the previous v3.5 question that was posted.
  2. Yes again, I was using the “Get-Help” instructions exactly as you posted.

My situation my be solved.

After Google-ing, I saw conflicting methods to perform the install. The difference being some suggest to use “yum” and others use “rpm” commands.

Since I was using yum, I changed to use rpm commands and that worked perfectly! I now have icons in my gnome menus and the app launches just fine.

I’m hoping someone can add some information as to why this worked or if there are side-effects to using rpm instead of yum.

Hmm, hmm, and more hmm. I’m mostly a Debian guy, so I’m not quite as familiar with rpm’s and yum. Glad to hear that you got things working; hopefully we can dig up someone to answer the ‘why’ of it for you :slight_smile:

Hi @SynAckZoo,

Looks like a similar error is reported on this question: 3.5 No Redhat Desktop-Integration package

You mention following install instructions on a website. Is that website this?

It looks like that get-help page contains install instructions for 3.3 and 3.4, and is possibly WAAAY out of date. I’ll try to ping someone about updating that page.