Problem with word-wrapped lines of bulleted list

I want to use a bulleted list in relatively narrow table cell, so that most of the entries in the list word-wrap within the cell.
I understand that there is increased line spacing between bullets (looks like about 1.5 lines). However this does not take into account word-wrap, so that the 1.5 line spacing appears between the first and second line of the word-wrapped text, while further lines of word-wrapped text are single line spaced. Also the spacing between the last word-wrapped line and the next bullet is single-spaced.
The makes the list look odd. I cannot see how to modify the bullet list style in order to fix this.
I set up the list using manual editing with the toolbar button.
Please note that I am using version under Raspian. This is the latest version for this OS.
I attach an example.

Bullet list in table example.odt

How are your bullet items created? Dedicated paragraph style or manual formatting with toolbar buttons?

The difference of spacing between 1st-2nd line and 2nd+ lines may result from the font used for yhe bullet and its size. Spacing between items may be set in the paragraph style. To clearly answer your problems, we need more technical details (better: attach a sample file to your question).

Additional information must be provided by editing your question, not using an answer because this site is not a discussion forum. Users are allowed only a single answer (for solutions). Comments are the nearest feature to a thread.

I don’t see the extra spacing between first and second line on my Fedora 30 Linux computer with LO 6.2.8. Text uses Liberation Serif 12pt and the bullet OpenSymbol 12pt without fancy positioning (no sub/superscript). Unless fonts are substituted under Raspian, I can’t explain why you have special spacing after the first line.

Since the bullet font is hard-coded in character style Bullet (the default style for formatting bullet), make sure this font is present in your OS. Otherwise, cutomise said character style, choosing a font which is metrics-compatible with the one used for the text of the list item to avoid the described problem.

Text in your table is styled Table Contents (which is the intended style) but bullets have been added with the tool bar button. Though this is a perfectly legitimate method, I prefer the other one of using a dedicated paragraph style turned into one for list (complicated sentence to tell I associate the paragraph style with a so-called list style, in fact a “sequence” style) because it allows a more targeted control on lists (when you have to-be-independent lists) than the default bullets (which apply to all lists).

Table Contents is meant for compact text formatting in tables, i.e. it does not provide extra space above and below paragraph. Modify the parameters in Table Contents, Indents é Spacing tab or, better, create a custom style derived from Table Contents.

The default bullet settings are controlled by Format>Bullets & Numbering. As shipped, bullets are indented from left 1/4" and text is aligned at 1/2". This setting is appropriate in full-width text since it makes the list stand out of regular text. However, in tables with relatively narrow cells, it leaves too much space at left for a poor visual effect.

Your example table shows borders. If cell contents is only made of bulleted items, it looks to me “pleonasmic” to use both bullets and borders. The result would be visually better (this is a personal opinion, YMMV) to type single standard (without bullet) Table Contents paragraphs, each in its own cell. You can then much more easily synchronise text in columns 2+ with the “bullet”. The alternate formatting is to remove the table borders.

Creating your own lists is a bit tricky. So read first the chapter about styles in the manual. This question will give you concise information on how to configure your own styles for list.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

Thanks for your answer. I just opened the file with Writer on a Windows computer. It looks fine, the problem does not appear. So it looks like the issue is specific to the Raspbian version.
I will try your suggestions later on today. Thanks again.

Following the comment by ajlittoz with regard to the OpenSymbol font, I found that it was not in the Raspian OS. I found it, downloaded and installed it. All I had to do is reopen the file and the problem was solved. No need for my previous “workaround” solution. (see below). Thank you ajlittoz.

I have found an acceptable solution to this problem. However I consider it a workaround rather than a true solution.
The problem I described remains for several different styles and different fonts which I tried. The only way I fixed it (sort of) is to change the line-spacing in the paragraph format (indents and spacing) to “fixed”. Other line-spacing options do not resolve the issue.
I also found that the problem is not limited to table cells, but also occurs when bullets word wrap across the whole page width.

Check that Raspian OS does provide OpenSymbol font, from which the “standard” bullets are taken. If font is not present, LO will substitute another one. If the metrics are not the same as the font for the paragraph, the problem you describe occurs. Setting line spacing to Fixed is the cure, so I wouldn’t qualify it a workarounf.

I edited my answer to include the solution. You can now tick it as solving the issue.