Punctuation marks seemingly change

I’m trying to type a bilingual English-Gothic document and the punctuation changes shape depending on the immediate adjacent character after it, be it a period, comma, colon, apostrophe, or any other punctuation mark.

If the text is Gothic and said character (highlighted in the pictures) is a space or Latin, the punctuation, in this case a question mark “?”, looks like this: a space and this: a Latin character. This question mark appears to match the Latin letters in weight.

Now compare with this question mark which appears to be visibly lighter in weight, matching its adjacent Gothic letter: a Gothic letter

The bolder Latin-matching question mark appears to be exactly like any font that is currently in use, while the lighter Gothic-matching one seems to be unchanged regardless of font, which I have tested. Any idea where the latter comes from and how to rectify this problem?

The language assigned to the text is English US. Using Windows 10 Pro x64, all settings in English US. LO version x64.


Hello @Vorichev, Are you adding the punctuation marks after text is written? Are you applying format on preexisting text?

Add Answer is reserved for solutions. Please, click edit below your question to add more information.

To be able to diagnose the issue, the exact Unicode character must be known, as well as the language assigned to text. Please, attach a 1-page sample file to your question. To do that, edit your question, scroll to the bottom and use the “paperclip” tool.

While editing, mention your OS name, locale and LO version. Is AutoCorrect enabled?

Please do not use Add Answer but edit your original question to enhance the details of your question (answers are reserved for solutions to a problem on this Q&A site).

Hi @LeroyG, no the punctuation marks are added as I type along. I don’t apply any formatting either.

@ajlittoz I have updated my question as per request.

Screen shot of the attached shared file: image description

There must be some formatting in the origiinal file that I don’t see in the shared file.

Unfortunately your Noto Serof font is not installed on my system and it gets substituted. I see correctly the Gothic glyphs because you rightfully encoded them in the Supplementary Multilingual Plane. All question marks in the sample are U+003F and display the same (probably because of substitution).

You could try to set the language for the Gothic sequences to Gothic language (this could hint the font renderer to use a different glyph for the question mark) but I haven’t found how to pass this language to Writer. ISO-639-2 code is got. I forced it by writing got in the dropdown menu and Writer reports the language in the bottom status bar as {got} (suggesting it has taken it into account) but I am not sure it can do something useful with it. Anyway it does not change the appearance of the question mark because I have no adequate font.

When I open the shared file in Window 10, I got some musical symbols (elipses with Eb, E#, etc, neighboring U+10339).

When the text is set to Segoe UI Historic, I can see something similar to the image I uploaded in my previous comment (Windows 7).