Recording a macro to index a selected word in Word, fails

Recording a macro to index a selected word in Word, fails each and every way I’ve tried, having been helped by knowledgable Linux, Kubuntu and Libreoffice users.

I can step through all the stages , (written down), and the process works, the selected word is added to the index.
If I preface these same steps with ‘Macro record’, then ‘stop recording’ with the mouse when completed, the word is not added and the running of the macro does not work either.

Clear and explicit instructions are needed to identify either a LibrOffice bug, A Kubuntu bug, a KDE bug or pilot error.

I’d be happy just to get it working.

Other macros that I write, work.



I don’t understand why you need a macro that will duplicate the existing Writer functionality. If your knowledge of macros is limited to using the Macro Recorder, then stop trying, it is useless (see Limitations of the macro recorder). If you are really a programmer, then try to understand this text and the example code.

The examples yo´ give are not for LibreOffice.

Whether or not you understand why, is irrelevant, I wanted to use the function.

I am not a programmer, most people in the world are NOT programers. You shouldn’t jump to conclusions.

You seem very aggressive. Calm down

Thank you though for providing some sort of answer.

I am an author.

I will move to windows to use word and its macro functions

I’m sad about that.

As an experienced Writer user, I have not yet felt the need for macros, though I write very sophisticated documents. However YMMV. But have you ever read the Writer Guide? It is not the ultimate manual but it gives you clear leads on Writer functionality.

When you switch from one app to another, you must imperatively force yourself to forget what you know about the previous app to fully appreciate the poxer of the newer one. Reading the manual is a prerequisite.

Thanks for your reply. I have done what you suggest, It won’t behave.

I can repeatedly do all the steps neccessary to index, and it works every time. But if I set a macro to record, stopping the recording does not add the word to the index.
I have been expoling other people’s knowledge for some weeks now, still no solution.
Creating an index, recording a macro, assigning a macro to a funtion key would take a lifetime without the manual.