remove file password protection

I have password protected a file and now want to unprotect it. How do I accomplish this?

(Your tags “calc” and “odt” don’t match.)
The simple answer: Enter the password when prompted for it.

However, I would assume you forgot the password.

If you did a “Save with password” the file is not just protected superficially but encrypted based on a strong algorithm. You may start reading this recent thread.

The questioner has clarified that he is possession of the password. The answer is to “Save As…” without password function checked, delete the original file and rename the new file to that of the old file.

Did you note that the “clarification” mentioned by you was later than my answer?
It was posted as a comment on an answer by someone else.
(Recommended: Questioners who found that clarification is needed should edit their questions to add information.)

You get to the password function through the Save As dialog, where you can overwrite the original file.

I didn’t forget the password. I only want to remove password protection from the file.

Save As, without the password function checked.

Thank you for actually answering the question, providing a working solution, correctly taking into account what the questioner required and the fact that they are already in possession of the password,

The response Lupp made 06/16/2018 is correct.

  1. Open the password-protected file. Of course, you must enter the correct password to open the file.
  2. Save the file without a password using menu choices: File → Save As… → and uncheck the “Save with password” button -->. Choose Replace when the message “File _____.ods already exists. Do you want to replace it?” appears.
  3. The file saved replaces the original file. The replacement file is not password protected. The replacement file has the same name as the original file if the user does not change the name.

However.

  1. If the application default is to save files with passwords, and
  2. If the File–> Save As… → option for saving is chosen, the “Save with password” button will by default be checked (activated). That is, the application defaults to “Save with password”, just as it has been set to do.
  3. if the user wants to reapply password protection, performing File–> Save as… allows this to happen.
  4. If the user chooses File–> Save, the file is saved without password protection and is opened without password protection.

The solutions mentioned don’t work (anymore?).

LibreOffice 7.0.1.2
The option in the “Save As…” dialog is called now “[ ] Save with password”.
It is unchecked by default.
It doesn’t matter if I check this option: The protected file is always saved with protection.

n.b. I also have the password.

n.b. it’s probably a bug.

n.b. Another funny bug: can’t compare protected files from Edit > Track Changes > Documents. It always says “wrong password” even if the password is correct (double checked, also copy-pasted).

There is a bug report When saving an encrypted document, unchecking ‘Save with password’ has no effect, encryption is kept tdf#133771