Slow typing with writer in Windows 11

They are problems with LibrOffice Writer in Windows 11. We are from a computer store and have this problems on all new computers.
When you install LibreOffice 7.2 or above the Writer program types verry slow. The charecters comes 3 to 10 seconds after the typing. So it’s difficult for typing, and the Writer is just for typing.
What i have tested:

  • New installation of Windows 11 with only Windows, the drivers and LibreOffice: Problem of slow typing
  • Installations of LibreOffice on more than 10 computers or laptops with Windows 11: allways the same problem.
  • Installation on Windows 10: no slow typing, no problems at all
    This are the versions i have tested:
    Libreoffice on Windows 10 Works perfectly
    Libreoffice on Windows 10 Works perfectly
    Libreoffice on Windows 11 Works not good, slow typing
    Libreoffice on Windows 11 Works not good, slow typing
    Libreoffice on Windows 11 Works perfectly
    Libreoffice on Windows 11 Works perfectly

We have also tested with other programs like: FreeOffice and OnlyOffice and there was no problem. Only with the latest versions of LibreOffice is the slow typing.
I have also enable/ disable openGL, java, etc. Same slow typing problem

The problem is only with Writer, not on Calc and other programs.


…enable/ disable openGL…

Do you mean Skia?

Please try Safe mode:

Select Help>Restart in Safe Mode… from the menu and report us.
Safe Mode

And have a look at:

General Installation Issues (Windows)

I suspect you might have disabled OpenCL which is used in Calc, instead of your intended target.

OpenGL was replaced by Skia a while ago, you can try going to Tools > Options > LibreOffice > View and untick the box Use Skia for all rendering

Having just resolved a problem in a different program on two different computers with different Intel graphics cards this morning by updating the drivers to the most recent, it might be worth exploring that avenue first.

1 Like

I have also started in safe mode: same problem
I have also deleted the profile: same problem


@Frederik1234 thank you for your interim report. When you have worked through the other hints, please report back here. Thank you.

I also tested the Skia disabled. The reason that i have done all this things before is that i asked first on the dutch forum, they said also the same posible solutions. See on dutch forum:

I have also tested on several computers:
Laptops with a Intel HD graphic card, computer with Nvidia graphic card, laptop with nvidia graphic card all same problem.
I have also installed on a new computer only Windows 11, the drivers and only libreoffice: same problem.
The problem is not with Windows 10, only with Windows 11. On the dutch forum they ask also for the drivers, i will check the drivers again en let it know.

I have tested now on a All-in-one computer with a Intel UHD 630 graphic chip. With the standard drivers, slow typing. I have updated the graphic drivers to the newest version. But same slow typing problem.
So it’s not a driver problem!
I have also tested on other laptops with intel graphics, and nvidia graphics, all with the newest drivers. Same problem.
It’s not a driver problem, but a problem with LibreOffice 7.1 or above

…or maybe with win11 …?

I have Win11 as an update on two laptops and there are no problems at all. (LibreOffice

I think you might be best reporting it as a bug. I was simplifying when I said that OpenGL was replaced; there are OpenGL settings still there which recently caused an issue for my UHD 620 card in Impress.
Please see:

When you do report it, could you please link the bug report here in the form of tdf#123456 where 123456 is the bug number, just don’t put it as pre-formatted text or it won’t turn into a hyperlink.

It might be worth checking if it is a printer driver problem. Try setting default printer to something built-in to Windows 11 such as Microsoft xps print driver or pdf driver and seeing if problem still exists.

I have heart form the Dutch forum also.
It’s only when you do a new installation of Windows 11. Not with a upgraded version of Windows 10 tot Windows 11.
But we are form a computer store and we install new computers with Windows 11 and LibreOffice. We sell also new computers with Linux, and there is no problem at all with LibreOffice.

1 Like

It’s not a printer driver problem, i have already tested and also i have tested with a completly new installation of Windows 11 without any other programs, only the drivers (chips, graphics, lan) and LibreOffice.

I have installed the new beta version: 7.3 and there is still the same problem.
I have also tested with a updated Windows 11 (Windows 10 updated to Windows 11) and there is no problem, you can normal typing.
The problem is just when you installed a new Windows 11 without upgrade from Windows 10.

It actually works so badly that I just can’t install it on new computers anymore. For now I will install the old version 7.0 but someday I will have to go to a newer version. So this problem will have to be solved somehow by the makers of LibreOffice.

1 Like

Unless you report it as a bug, how will they know that it needs fixing? Please report it and link to bug report here and on Dutch forum. Cheers, Al

I have reported as bug, a few days ago, here is the link:
But i am not so familiar with bug reports, i hope i did it good.

1 Like

So, it happens to me also.
My configuration is an Asus Zenbook 14 Laptop with:

  • Ryzen 7 3700U
  • Vega 10 Integrated Graphics
  • Windows 11 22000.438

Under the last 7.2.X or 7.3 releases the word I’m typping doesn’t appear until I writed it entirely.

Also, if I downgrade to, Writer works perfectly. No matter the configuration of Skia/HW acceleration.

1 Like

First thank you Frederik1234 for your efforts! Frederik1234 has described my problem exactly with regards to LibreWriter. I have a new laptop that came with Windows 11.

I have also attempted the listed possible fixes enabling and disabling various combinations of settings as well as Safe Mode with several of the latest versions of LO.

i7-11800H @ 2.30GHz
16.0 GB
RTX 3060
Windows 11 22000.493

uninstall newest version and install prior. it doesn’t have the speed problem.