[SOLVED] Calc - Delete Cell also deletes another cell in same row

Using Windows 7 Pro x64 fully patched and LO

Open the attached file in Calc 5.3.?.? then delete any cell in column A with your keyboard delete key. You’ll notice that the adjacent cell in Column B on the same row is also deleted. Vice versa works as well (delete B, A is deleted - only for the rows that have cell’s filled in Column A and B.

I do not know why this is happening, but it only started on I am running on a 64bit Linux and it’s fine. No issue with this exact same file. I can’t seem to reproduce it on a new spreadsheet as well in Thoughts?

Not for me with Version: (x64), it’s very strange issue.

Please try resetting the user profile, sometimes solves strange issues.
Usually it’s enough renaming/deleting the file “user/registrymodifications.xcu”, it affects all the options in Menu/Tools/Options, and the files “user/basic/dialog.xlc” and “scrip.xlc” are overwritten, additionally custom colors in “user/config/standard.soc” are lost.

Problem repeats on three different workstations using Windows 7 x64 and Windows 2008 R2 x64 using different Windows/LibreOffice user profiles and all running various versions of 5.3.x. I also tried and it exhibits the exact same problem on my workstation. Could all of our LibreOffice profiles have these issues you describe? I’ve never seen anything like this. I will try deleting the files you describe, but whatever has happened - has happened to all of our workstations…

One thing that is consistent in our environment that may be different from others is that we utilize a lot of Remote Desktop Connections to access Windows. We’ve noticed some Dialog Boxes are not showing all text under 5.3 and 5.4 - I wonder if this is a glyph or bitmap issue under RDP…I’ll go down that road if your idea does not work…

May it be that the cell content actually isn’t deleted, but the RD gets confused and fails to display things correctly? What if deleting one cell and saving the document and opening it in a known good environment, is the “lost” cell still there?

It’s definitely something to do with RDP / Remote desktop connection. 5.2.x has no issues under Windows 7 / Windows 2008 R2. 5.3.3+ most definitely does. It’s reproducible on 6 different workstations. All of us are connecting via xfreerdp on Suse Linux Enterprise Desktop 12 and from Microsoft Windows 10 Remote Desktop Connection. I’ll call this solved, but I’m going to have to post a new question/bug if I can’t find something in bugzilla that covers this (always fun to search in).

[SOLVED] (Well, sort-of solved) This bug covers it, it is very similar to what we are seeing under RDP;
Bug 107166