[Solved] Field separator in header sub-chapter with number

I wanted to use in a header the sub-chapter with the number. I did ask this in my previous thread of
Header with sub-chapters as content which was half successful.

Half because I could add a sub-chapter but not exactly as I would like. I could place the field, but sometime a bit difficult to right align. The field, marked in grey, has a large empty space behind, which can not be removed easily. I could succeed after all although I can not reproduce what I did, a bit scary. But I do accept.

I would like the have the field with heading numbers. I could do so but, without a space as separator, which looks ugly.

I would like a space between “1.1” and “The main thing” I attached the stripped file to only 3 pages see: .test_04.odt

I followed the remarks of ajlittoz with the following results:

image description

which is ok. The second right header is using tabs but is not ok:

image description

Also with align this is not ok but in a different way:

image description

I can enter not the field of “Uitdagingen” to remove the spaces. Beside it is weird, the first page header is ok, the second is not.

While trying to adjust settings a few time my settings were lost when trying to access them again. Beside inconvenient this is also very confusing. I do not know for sure anymore which properties have which value.

See the document: test_10.odt

Edit your question to attach an example of your present “failure”. This will be much easier to suggest a fix.

I asked you to attach a sample file (2-3 pages max) to the question. You edited with screenshots which don’t allow to check all the page, paragraph and style properties. You didn’t even enable View>Formatting Marks which could have given clues about your work routine.

Mention your OS and LO version. I don’t recognise the UI; which user interface have you selected?

Sorry for that. Sorry to say I did not get a message you replied, so I respond lately. Sorry for that. My original document contains now 23 pages and I do not want to make that public. So I saved it as template (.ott) and tried to remove the text. With conditional page breaks. But because doing so the header functionality changes. I would like to build a template with all the functionality I need. For that I first need to create a document where all aspect, with content, appear. Then delete the content and save it as a template.

Now working on the document, the header does change again, even in the previous files. I thought style are part of the document itself. Is that true ajlittoz? Because If so, that should not happen.

I have Ubuntu 20.04, LibreOffice 7.0.4.2 using standard user interface.

To create a sample, make a copy of your document. Remove text before and after the occurrence of the mishap, keeping only ~3 pages. If text is still private here, replace it with dummy text. You can do it easily typing “lorem” (without quotes) and immediately F3. Delete excess text.

I did check my question and saw there was no attached file. I added this now.

Remove the spacing in Heading 2 Uitdagingen (in text, not in header) and everything should be back to normal.

Of course. With hindsight it is obvious. But to find it, before, like you did, is hard. I appreciate your explanation and get the feeling I understand a bit more of styles. Thanks ajlittoz

@Bernard12: you don’t have to tag a question as Solved as in the Apache OpenOffice forum here. On this board, you mark as question as solved by accepting the answer. Alex Kemp has done that for you already.

@floris_v, Thanks I was searching already how to do this. I will retake also my previous questions.

##Heading in header

IMHO the composite field “Chapter number and name” has low utility. As you noticed, the number is prefixed to the chapter name with nothing in between. From an author or formatter point of view, it is much better to insert separately the number and the name so that you can add whatever “separator” you like between the two elements.

This separator can be a space, a tab, a dash, a column or even a set of words. You have thus full control over the look of your header.

##Header alignment

Your document uses Left Page and Right Page page styles to alternate page formatting. However, you slightly messed the settings resulting in a small vertical misalignment of headers.

Left Page Header sets height to 0.5cm while Right Page Header sets it to 0.1cm. AutoFit height can’t compensate for the difference because 0.1cm adjusted for the font used remains smaller than 0.5cm.

You have customised Left Page and Right Page to A5 format. This has a consequence on Header paragraph style and all those inheriting from it. Built-in Header paragraph style has tab stop definitions valid for A4: on centering tab stop at 8.5cm (center of sheet) and one right-aligning tab stop at 17cm (right edge of sheet with default 2cm margins). These tab stop positions remain the same when you change paper size because there is no connection between paragraph and page styles.

Usually (in A4 portrait format), you just type data for left edge, enter a tab for center data and type another tab for right-aligned data. With A5 paper, this scheme is defeated because the first tab is no longer at center of sheet. Also if you reset the first tab stop at center, left data may be too wide and already reach the center. If you need to have all three pieces of data (which does not seem to be your case), you may be in trouble.

Nothing to say for your left pages under Left Page page style with a header as Header paragraph style.

Your right page uses Right Page page style and Header Left as header paragraph style. Though it does not matter, it would be better from a “logical” point of view to use Header Right and, even better, you can use also Header.

You added a right-alignment direct formatting to your right header. There is no use for it.

As mentioned above, in A4, you would only type two tabs to send your sub-chapter to the third element location and it would be right-aligned. You’re in A5 format without modification on Header. The tab stops no longer match this paper size.

When you type a tab, your header is centered on the 8.5cm position which is no longer in the center of the sheet, leaving blank space at right. If you enter 2 tabs, the header is sent to the right but is split on the following line because you can’t stop at 17cm because maximum distance is now 10.8cm.

You can fix it by changing the tab stops in Header paragraph style so that they match the A5 paper size.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

@ajlittoz Thanks a lot for your thorough research. I will dig into this and come back with my results.