Solved - I Cannot add records in a form

I’m using Base 6.2 with the firebird embedded database. The table has a primary key CharID. The primary key is on the form. The error is validation error for column “Characters”.“CharID”, value "** null ***".


It appears you are attempting to enter a new record without any value in the primary key field:

image description

If the key is to be system generated, the table field need to be set to auto increment:

image description

Then the record will insert properly:

image description


image description

Optionally, you could always enter your own ID in the key field instead of an auto increment field. Of course it needs to be unique int the table.

This is the problem. I’ve tried to set the field to auto increment but no go. I apparrently cannot change the primary key field after table creation with firebird. I’ll recreate in hsqldb and see if I can get this to work.

@timstearns2 Actually adding it is relatively easy - delete the old field & add a new one with the correct setting. Just ran test of same without a problem - without data in table.