[Solved] Menu Bar Icons Missing

The upgrade to broke the menu bar icons. I’m running Linux Mint 18.1. I did a full clean install and the problem did not go away. I reverted to and the problem has resolved. Here is a screenshot of the problem:

Had the very same problem after upgrading to (Debian / Buster) the other day. Here is what solved the problem for me:

Go to Tools->Options->View

See what you have under “Icon Style”. In my case it was set to “Automatic(Helpimg)”. I changed this to “Galaxy” and after a restart, my icons were back. If you can’t choose a style you may need to install one. For Debian/Buster I see the following options:

v   libreoffice-style                                                                           -                                                                                                       
p   libreoffice-style-breeze                                                                    - office productivity suite -- Breeze symbol style                                                      
v   libreoffice-style-default                                                                   -                                                                                                       
i A libreoffice-style-galaxy                                                                    - office productivity suite -- Galaxy (Default) symbol style                                            
p   libreoffice-style-hicontrast                                                                - office productivity suite -- Hicontrast symbol style                                                  
p   libreoffice-style-oxygen                                                                    - office productivity suite -- Oxygen symbol style                                                      
p   libreoffice-style-sifr                                                                      - office productivity suite -- Sifr symbol style                                                        
p   libreoffice-style-tango                                                                     - office productivity suite -- Tango symbol style ``` 

Afterwards you should be able to select it and your icons should re-appear after restart.


-- B

Check the settings for toolbars. From menu Tools->Customize. Select Toolbars tab. Make sure corect Style is selected (Icons or Icons & Text or Text). Having no problem with v5.4.0.3 on Mint 18.1:

Edit 08/03/2017:

Please note answer by @Brainslug (+1 to you!). Having looked at my settings, I had set Tango icon style long ago and it has carried forward. If I change to Helpimg style I get the same view as @farside268

Hi, the same problem here with the greek version, but solved with the above change in the icon style.

Is there a way to do that from command line or by a script-like type of way?

Thanks in advance

Your response is not really an answer, and you are asking something different from what was originally asked. The appropriate way to do this would be to delete this answer and open a new question instead. Reference this question in a link. For guidelines on asking questions, see here.