Libre Office Custom Toolbar Icons Not Appearing

I just installed LibreOffice installed and when I tried to create a new toolbar (in LO) and select to show icons only, the icons would appear. But when I restarted LO only the text labels would appear. I tried this with built-in icons and my own .pngs in the appropriate size. I have searched the web, including here, but only got a few scraps of information. This link describes the situation, some what:

and tried changing the Icon Style, but to no avail.

This link: Cannot print anything, exporting to PDF produces blank PDF (Lubuntu 20.04)
linked from the first webpage, indicates libreoffice-qt5 should not be installed and I only have the gtk3 version installed

According to this:

“there seem to be many problems with latest release ubuntu 20.04 based distributions”…

I tried replacing libreoffice-gtk3 with libreoffice-qt5 with libreoffice-gtk, but this did not change the behaviour.

Has there been any solution found?

Many thanks.

Otherwise this is a great new version!

All of links are broken in your question.

For Fedora 32 Cinnamon Desktop Spins + LibreOffice, please see TDF136218 .

Thank you for this information. I’m using the latest Cinnamon with the LO6, so it must be a Cinnamon problem, I guess, though I thought there might have been a work around by now.