SOLVED: vlookup formula just remains in cell, no error

I have 2 worksheets, {same file} one with a column which has a drop down list and a 2nd worksheet with sorted data and memo type information {in the 2nd column or B column}. I’m trying to retrieve that 2nd column information.

In sheet 1 the drop down list in column E works fine but when I enter a VLOOKUP formula to column F that formula just remains in the cell in a light green color. No error but also no data.

This is an example of the formula entered: =VLOOKUP(E3,$‘Payee-Depost-List’.A$2:B$62,2,0)
I’ve also tried the same formula but without the “$” for the cell references but no difference.

I tried entering a “!” right after the $‘Payee-Deposit-List’ sheet name as I’ve seen that on the numerous tutorials I’ve seen but all that does for some reason is put the entire sheet name in lower case. =VLOOKUP(E6,$‘payee-depost-list’!.A2:B50,2,0)

I’ve never had a case where I’ve entered a formula and the formula just remained visible in the cell. Usually I’d get an error which would give me a clue to my mistake.

@CMWhitley, check menu View - Show Formula. And maybe also menu View - Value Highlighting.

Tested with LibreOffice (x86); OS: Windows 6.1.

Add Answer is reserved for solutions. Please, click edit below your question if you want to add more information.

@CMWhitley, Can you share how do you solved the issue? Thanks.