Spell Check Frozen

Is there a reason why the Spell Check will just freeze up and do nothing. This is on a four-page document with no template or special formats, not as terribly long as my documents can go. Just now I made some changes in Options so that it corrects as one types. Still, it is not checking the document.

Thank you to whoever answers this.


Forgive me for forgetting that I am not the only one using this program. LibreOffice v. 7.0.22 runs on my Windows 7 64-Bit. It is set to the default language, English-US. Under Options everything is checked except “Hyphenate without inquiry” and “Check spelling as you type.” There are all five dictionaries checked. Yesterday I checked those last two options just before posting this thread and clicked Apply. They were not checked as I brought Options up like I expected. I had the idea that Options were specific to the document.

(edited by ajlittoz to make clear what was added in the edit)

Edit your question for OS name and LO version. Are you writing in your native language or a foreign one? Are dictionaries installed and enabled in Tools>Options, Language Settings>Writing Aids?

On this site, answers are reserved for solutions. Be sure to edit to answer these questions.

  1. Read this tutorial.
  2. If you can’t find an answer, read these guidelines and ask a good question.

I had the idea that Options were specific to the document.

Yes and no: some are attached to the document at creation time but most of them are user-specific, meaning they are stored in your user profile and restored when you launch LO.

Those which can be document-specific are stored in the document and reloaded. They then override the user options.

To see if this mishap is related to your document, attach it to your question (edit the question and use the paperclip tool). In case you consider document content private, replace it with nonsense or “lorem ipsum” taking care that the problem is still present.

I did not understand that last part as it sounds like I am to create another document with only the words “lorem ipsum” in the text. However, I ran the Spell Check again and paid more attention. It stopped on the first of spacing errors I made, like double spaces instead of single space between words in a sentence. One error was lack of a space between " and the next word. Anyway, once I recognized why it stopped, it found everything. Thanks.

@tightpurchaser: I used “lorem ipsum” as a verb to mean "replace text with text lorem-ipsum-like. This text can be generated typing “lorem ipsum” and pressing F3 at least when language is English. Creating a new document from scratch may clear the problem.

If the issue is fixed, please close the question with reason “outdated or no longer relevant”. Thanks.