Spellcheck in LibreOffice Writer displaying [None] even with language selected

Hello everyone! Thank you so much for reading.

For a day or so now my spellcheck has been broken :c just not checking anything, I clearly have mistakes in my paper but it won’t check them or flag them. This is what I see:

It’s been driving me crazy :c I’ve set the language in tools > options > language settings, I’ve set it in the default paragraph style. I’ve tried setting it in the bottom bar on the screen, selecting all text, and toggling between languages. None of those fixes have worked for me.

Heres what I see at the bottom of the page after using the tools > options > language settings as well as setting the language manually, and editing the default paragraph style. (all 3 fixes I’ve tried)

image description

Any help would be super appreciated! Thank you!

In your document, do you have multiple languages that you want in it? If you want only one, then click Tools > Language > For All Text > [YourLanguage]

Otherwise select the text you want in one language, say English (USA) then at the bottom of the window, click on the language bar and select English (USA), repeat for other languages.

[None] means don’t spell check

Thanks for the reply! But I already tried that, the language is set. and I’m only using one. and I’ve applied it to all text on the document, as well as system-wide. Despite it showing up n the bottom of the window. Spellcheck still says none.

  1. Read this tutorial.
  2. If you can’t find an answer, read these guidelines and ask a good question. In particular, if it is a problem with a file, show the file.

Spelling (None) and blank for Text languages means that no language was applied to the text under inspection. Therefore, the spell check will ignore that text and not notice any errors.

@gabix thank you for your reply. I followed that tutorial and have had no results. that one was published in 2007 and the blue checkmark no longer shows up. Should I try uploading my paper here?

@floris-v all the text of the document is set to English (USA) and I can select individual paragraphs, the language is set there and in default paragraph style yet spellcheck still refuses to show it.

If the checkmark doesn’t appear, your user profile has become corrupted and LO can’t find the dictionary.

I followed that tutorial

What exactly did you do? What were the results? And yes, once again, show the file.

What OS? Could it be Fedora?

Reset your user profile. See LibreOffice user profile - The Document Foundation Wiki for help. Note: you rename the old profile, so your user settings are safe, and you can later copy them from the old profile to the new one. Do that when LibreOffice is not running.

To show the community that your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers.