Status bar SUM not working across sheets properly

SUM which is located in status bar, on the right side (where you can choose between sum, average, count, etc) is not working correctly on some PCs I have.

At my workplace I have winXP SP3 with Libre Office Version: :
When I select any cell with multiple sheets selected - it shows me the sum of that cell from every sheet. This is super useful behaviour.

At my home, with latest (as of 25/2/2015) version of Libre Office and windows 8.1 fresh install (also tried windows 10 tech preview) it counts the sum only on a single sheet, ignoring the rest of them.

Only difference between OS version that I could think of - XP machine has Java installed. I could’ve just installed Java on those home machines but I RATHER NOT, if it can be avoided.

For now I know I can make SUM(Sheet1.C33:Sheet3.C33) and etc, but thats not as nearly useful.
Any insights? Is it Java?

Filed as bug at tdf#103684.

Thank you very much for recognising the bug and fixing it too. I’ve downloaded 5.4.1 and the bug does seem to be fixed now. Thanks once again.

I don’t use that facility on a regular basis, but just tried it with Win versions 3.6.5 (portable), 4.3.5 (portable) and 4.4.1 (installed under Win 8.1).
Everyone behaves unchanged wheter or not I switch on Java.
Only the one version from the 3.x series is beahving as you expect (with reserve). The 4.x versions only take in account the foreground sheet.

The reserve: Adding sheets to the multiselection or removing sheets from it will not correctly recalculate the SUM (or COUNT or whatever) for the preselected range. You have to select a range anew or change the view selection for the status bar …

Can we reliably use features of that class (implemented without full responsibility in mind)? I personally much prefer non-existing features over pretentious ones.

Reading your answer inspired me to try 4.4.1 portable on XP machine and yes, it’s not working, while 4.5.2 still does. So the problem lies in version number and not my setup.

I think you’ll get things working correctly up to version 4.2.8 but not thereafter. I have a related issue about copying values in cell A1 on 10 sheets from one file to 10 sheets on another file.

I’m still waiting for that to be attended to as well.

It’s also a bug at

Which is completely not an answer to the original question.