Strange Characters with Liberation Fonts

I have had this issue in the past with earlier versions of LibreOffice on Windows (7.0.4), see this question Previous Question on Ask LibreOffice.

The above issue was tied to an Impress Template that was in Spanish Argentina and embedded fonts. I was able to fix that issue by:

  1. Going to the Impress Presentation File “Properties” and turning off “Embed Fonts”
  2. Switching to “English (USA)” for the language
  3. Closing and reopening the file.

Yesterday, I opened one of those Impress Files to edit it. I did the steps above on that file, but now every file that I open that uses Liberation Serif of Liberation Sans Fonts has these strange characters for double quotes, single quotes, and apostrophes. I have double checked the Language settings in the LibreOffice, they are set to “English (USA)”. I have double checked the default style which is also “English (USA)”. If I switch to a different font everything looks normal, and when I switch back to Liberation Serif or Liberation Sans I get the strange characters again.

I really don’t want to go through all of my documents and switch out the default font to something other than Liberation Serif or Sans. I use those fonts in my templates because I know that they will be there on both my Windows 10 install and my varied Linux installs. By the way these same files look fine on Linux in LibreOffice earlier versions (Debian’s 6.1, and Fedora which might be 7.0 or newer.)

As you can see from the screenshots below I have English (USA) turned on. Did I miss something or did opening that file that was encoded with Spanish Argentina cause a bug that has messed up my latest install of LibreOffice

Ok, this isn’t really an answer, I don’t think. But I just did a Windows 10 reboot, and opened a new document, and Liberation Serif and Liberation Sans is displaying double quotes, single quotes, and apostrophes correctly.

In Windows, WindowsKey+Space changes your Language input options. The Windows default is to have Ctrl+Shift change Language. Keep an eye on the Language Preferences on the taskbar, next to the time, to make sure the keyboard and the language remain the same as you want them. Cheers, Al

@Earnest AI, I only have one language installed, English (USA), on Windows 10 so the language icon doesn’t even appear near the clock in the Win10 taskbar. So this must be an issue with LibreOffice. I’m guessing that when I did a reboot, I cleared some setting in LibreOffice that survives from session to session until a reboot occurs and that is why I was stuck in what I think was Spanish (Argentina) which was caused by opening a file with embedded fonts in that file. It is strange, that I’m only seeing this in the Window version of LibreOffice. When I open the same files in Linux in earlier versions of LibreOffice like the 6.1 (Debian Stable version) I don’t have this issue of languages at all. It seems to respect what I have set in the Linux system as the default local.