Styles & Formatting icon is broken

This is a block on me using ‘Writer’. I am using Win7.
I upgraded from Libre ‘Office’ 5.4.6 to and can no longer work with any of my documents which use Table of Contents and or Headings - which is most of them.

I have the following two tool buttons visible on my top menu bar:
‘Style’ (Which has a pop-up description: ‘Set Paragraph Style’)
‘Show the Styles Sidebar’ (in Win7 this button design is a capital ‘T’ partially masked in the bottom-left by a green triangle).

To change the font or other aspects of a heading, for example ‘Heading 1’, my technique, which no longer works, was:

  1. Click ‘Set Paragraph Style’ to open a vertical/“drop-down” list of styles (or click the button who’s pop-up description was ‘Show the Styles Sidebar’ to open a floating box titled ‘Styles & Formatting’)
  2. Scroll to ‘Heading 1’
  3. Right-click ‘Heading 1’
  4. Select ‘Modify’: This would open a box titled ‘Paragraph Style: Heading 1’ which had a number of tabs.
  5. Select the appropriate tab (eg. the ‘Font’ tab or the ‘Indents & Spacing’ tab) and make the desired changes to the heading.

The technique no longer works.

  • Clicking ‘Set Paragraph Style’ creates the vertical list of Styles & Formatting’ and I can scroll to ‘Heading 1’ but if I right-click ‘Heading 1’ then all the text in the document where the cursor is positioned changes to the existing setting for Heading 1! The option to select ‘Modify’ no longer appears.
  • The ‘Show the Styles Sidebar’ button on the top menu bar no longer works (I only get a momentary glimpse of the 'Paragraph Style … ’ box).

As far as i can see, this bug was reported in February 2018 and in March 2018:
Previous bug report

Heh, and how that is related to the bug you mentioned as “not fixed” in your comment here?

And I have just checked, that in that worked just as in later versions: right-clicking on any entry in the Set Paragraph Style drop-down list just applies the style to the current paragraph. Nothing changed, works as expected. F11 allows to modify.

Also, before anything else, please try resetting your profile to see if that helps with the problem where “‘Show the Styles Sidebar’ button on the top menu bar no longer works”.

Note that what you mentioned as “previous bug report” is not a bug report, but a question on this Ask site (just like yours). Bug reports are off-topic here.

Thanks for your help. I removed v6.0.6.2 and installed v5.4.6.2. I was at fault expecting to use the ‘Paragraph Style’ feature to modify when I can’t, even though it is intuitive to have that expectation. However, in if i click the ‘Styles & Formatting’ icon the ‘Styles & Formatting’ box only appears for an instant, preventing using it to modify headings. In v5.4.6.2 clicking the Styles & Formatting icon brings up the ‘Styles & Formatting’ box as normal, allowing heading modification.

Have you tried to reset the profile before removal of 6.0.6?

I will stick with v5.4.6.2 for now as it works and doesn’t work. When i have time to figure out what is meant by resetting my profile I will try Thanks again for your help.

Our last two comments were posted simultaneously

No I didn’t try to reset my profile before removing No idea what ‘profile’ is or does or how to access it. I’ll have a look now

OK, I get the picture. I’ll upgrade to as soon as i can, reset my profile, see if the ‘Styles & Formating’ icon works and allows me to modify headings and post the result here.

thank you!