sudden change in tab stop behavior?

US Letter size paper. Left margin 1.5". Style had “Before text = -0.75” (negative spacing), and a tab stop set at 0.75". This was so I could put a number out in the margin and then tab into where the main text margin starts. This worked until just a few minutes ago. It does not look like LibreOffice updated. Check for updates says it is up to date. Suddenly, the tab stops are relative to the page margin, not to where the line actually starts, so I have to set a tab stop at 0.00" to tab back to where the margin of other styles is. Also, the default tabs stopped lining up with half inch margins. I checked Options > Writer > General and they were set to 0.49". Whether I set to 0.49" or 0.50" it doesn’t matter, they don’t line up with the rest of the ruler even on a line with default style and no negative or positive indentation. What gives? This is version

You should have “First Line” set to -0.75" (not “Before text”), and you don’t need a tab-stop – just leave “Before Text” to 0.0", and LibO will automatically create a tab to that position. (It’s not crystal clear to me what your 1.5" “left margin” is set for: is that the page margin? or a paragraph setting?)

Check out the answers to this earlier Q&A on hanging indents and tabs, which also deals with hanging indents and explains about the non-need of tab-stop-setting in that situation.

Caveat: I’m still on, so it is within the realm of the possible that your experience with could be different.

If in doubt, it would always help to upload a test document so we could see exactly what you’re dealing with.

To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!