Table of Contents adding leading dot before page numbers


I expect there to be no leading dot before the number. I expect that there will be the character of periods in a row between the ToC reference and the page number. Thats what the table of contents instructs in the Entries tab with “Fill Character .”

What I expect and used to have in prior versions of LO is

What I actually get is

Edit ToC Dialogue Box

With tthe leading dot

With no leading dot which is what I seek.
no leading dot

Does that make it clearer?

I would be happy to report a bug if it is one. I strongly suspect user error, however. If it turns out that I am not making mistakes, I will report it. Meanwhile, thank you for the “use parallel versions” tip.
[The probelm is that I was a mathematician, not an engineer, so it has to be RIGHT, not just work. It’s a whole mental illness thing. Drives my engineer husband nuts. As his satisfaction of just getting it to work drives me nutso!]


Here are two versions of a document which I have pared down considerably, but believe have left enough information so that someone might be able to help me. Every style is represented (I believe).
This issue has to do with the Table of Contents and every other index.

On the BRIEF PAGE NOS CORRECT it operates as it always has.
On the BRIEF NUMBERS BROKEN a dot appears before the page numbers in the TOC.
I can find neither rhyme nor reason.
It has occurred when I have deleted some pages. Restoring via [CTRL] Z does not solve the problem.
It has happened when I alter the style for Contents 2. Reverting does not solve the problem.
I have not messed with editing the index because I don’t know how so that is unlikely to be the problem unless it auto-incorrects in some form or fashion. I also haven’t investigated that. Hoping for an easy cure :slight_smile:

Obviously there is a Thing I have Done Wrong but I am at a complete loss.

I did find this same problem reported about 2/24/24

And in AskLO I found the following:
This did not help me solve the problem and I can’t find the issue here.

BRAND NEW RELEASE - At least ASCII codes are working now, but…
Version: (X86_64) / LibreOffice Community
Build ID: db4def46b0453cc22e2d0305797cf981b68ef5ac
CPU threads: 16; OS: Windows 10.0 Build 19045; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL threaded

But wait! There’s more!
Here is a third document. I attach it and the PDF.
When I look at the screen, it shows me the (evil) leading dot.
When I look at it through “Toggle Print Preview” [from the toolbar button, not Ctrl+Shift+O] the leading dot is gone.
Brief ToC updated Nos Broke in WYSIWYG render and PDF print (Foxit) not in print preview from tool bar.odt (55.5 KB)
Brief ToC updated Nos Broke in render not in print.odt.pdf (466.4 KB)

When I print it to PDF the dots show back up.
When I print it (HP OJ Pro 8740) the (evil) dots show up on many, not all, of the lines.

Device name
Processor 11th Gen Intel(R) Core™ i7-11800H @ 2.30GHz 2.30 GHz
Installed RAM 64.0 GB (63.7 GB usable)
Device ID AF1DC4AB-017B-4D21-A8D0-90CC4101A7B6
Product ID 00326-10000-00000-AA153
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Win 10
V. 22H2 9OS Build 19045, 4046)

Brief Numbers Broken.odt (73.0 KB)
Brief page nos correct.odt (84.8 KB)

Could you be more precise and descriptive? When I open these documents on my Fedora 39 with LO (not yet updated to 24.2.x), both documents look the same, i.e. heading contents followed by leading dots followed by page number. This is requested by the TOC configuration where the tab asks for a leading line made of dots.

What does “a dot appears before the page number” mean? A single dot without leader line? Do you expect no leader at all?

Best to report a bug for 24.2, it seems to be a graphical / zoom level bug that somehow gets exported to pdf. How to Report Bugs in LibreOffice - The Document Foundation Wiki

In the meantime, it might be better to revert to an earlier version for your work. Maybe use parallel versions, Installing in parallel on Windows - The Document Foundation Wiki

1 Like

I edited my initial posting. Don’t know if that was correct. Maybe I should have responded here? Still learning the board.

The bug has been accepted, and I linked back to this post, so I think you’re fine - you spotted it initially, and the wheels are now in motion…

This has now been fixed (from what I’ve tested, anyway) in the nightly/development builds, so will find its way to the next update release in due course.

1 Like

Oooh! Nightlies! Haven’t done those since Cyanogenmod. Guess I’ll google it. I assume that I can have both installed?

Ha! I was Cyanogenmod-ing once as well…

Yes, they install in parallel under a “dev-” name, and you can remove them later (that’s how it worked under Linux, anyway). Or just wait for the next point release…

I am installing it even as we speak.

FWIW, it’s not user error - I’ve just tried creating a ToC on LO Ubuntu, and had exactly the same behaviour.

And it’s not a rendering/zoom or export-to-PDF issue: it’s in the original document, visible in edit mode, page preview, and anything else I try. Whatever I do, there’s a rogue dot immediately before the page number, with a gap between that and the line of dots that lead from the ToC entry (the “extended ellipsis”, if you like).

I’ll dig around further, but it looks like an unintended feature to me…

1 Like

@janehull I’ve raised a bug for this, so let’s see what people think.

1 Like

Thank you for reporting the bug.
Please do not use Suggest a solution for comments. Instead, click on a comment bubble to add a comment.