Text colors doesn't work

I was using LibreOffice 6.4 and I opened Writer and tried to change the color of text from black to red, and it didn’t work. Then I downloaded the version of LibreOffice 7.0, I opened Writer again and I tried to change the color of text from black to red, and it didn’t work too.

I use operating system Linux Debian 10.

Someone knows anything about that?


tried to change the color of text from black to red, and it didn’t work too.

  • How did you do that?
  • Did you do that on a new document?
  • Did you do that opening existing document(s) (If yes, which format do these document use [.odt or other])
  • Did you try to change the color, while running LibreOffice in Safe Mode (`Help-> Restart in Safe Mode…)?

Same here:
Updated to LO7 from 6.3 (x64, firebird, win7);
-on existing Base forms, all text font colors (including on buttons) are reset to black
-properties still show original selected color and usual options
-‘apply & ok’ dialogs appear to run when selecting font-effects:color in those properties
-BUT nothing will change that black font :confused:

Hopefully this is an easy fix …
(Love you Libre!)

PS - just tried with a new Base (firebird) database + new form >>> Font color not working on BUTTONS !

I tried to change text color by the button “Font Color”, normally.
For new documents it appears to be ok. But, for old documents this inconsistency occurs.
The document, where this error occurs, had been saved as “.doc”. It was made in LibreOffice Writer, but it was opened and changed in Microsoft Word too. After, it was reopened in LibreOffice again. Then, I saved it like “.odt”, but the error persist.
In safe mode, I tested now, it works for one document perfectly. But for another one, when I try to change text color (black) to red, Writer shows yellow.

May be menu Edit - Track Changes is set to Record.

i have just verified, it is not set to record.

In the old documents?

I’m providing the document that generated problems. Who want to test it, can do the download: link to download the document

The text is in another language, Portuguese.

If you try to change texto color in LibreOffice 6.4 or 7.0 the problems happens. For exemplo: try to chance underlined text color, it doesn’t work. And try to change text color (not underlined) to red, for example for you see about I’m speaking about.

Remembering I’m using Linux Debian 10. I don’t know if this inconsistency occurs in Windows.


contrary to your comment above the document has Edit -> Track Changes -> Record enabled and therefore you get the colors defined as per Tools -> Options -> LibreOffice Writer -> Changes (which are by default set to Automatic so each editor of the document has its own change color).

  • Disable Edit -> Track Changes -> Record (CTRL+SHIFT+C) and you can change the text color.
  • Edit -> Track Changes -> Accept All to accept all changes made so far.

See the following modified document: RelatorioCOVID19-NoTrackChanges.odt

Accidental remark: Consider to save in ODF format (.odt). Sooner or later you will suffer from compatibility issues. If you are interested in why this may happen, you may want to read this Tutorial - Differences between Writer and MS Word files (View topic) • Apache OpenOffice Community Forum

Hope that helps.

Well, firstly thank you very much!
I’m trying to understand what has happened.
This option you mentioned “Edit → Track Changes → Record (CTRL+SHIFT+C)” is set by document and not for the application, I didn’t know that. And second, maybe I have pressed “Ctrl + Shif + c” accidentally. Because in Linux Debian, if you want to copy something from Terminal (like Windows’s Prompt) to any graphical application, you use exactly “Ctrl + Shift + c” to copy. But, to paste in graphical application you use “Ctrl + v”. And opposite, if you want to copy from graphical application to Terminal, then you use “Ctrl + c” to copy and “Ctrl + Shift + v” to paste.
More one time, thank you very much!

Your understanding is the general explanation for inadvertent activation of Track Changes recording.

*If the answer helped to solve your problem, please click the check mark (✔) next to the answer.*

I am having a similar issue with LibreOffice (x64) in Windows 10. In a new document, I cannot change the color of selected text. If I turn off “Record changes,” clicking on the Font Color button simple makes the selected text bold. Like eddiesaliba, I had this problem in an earlier version (6.4.?), so I updated yesterday to 7.0. Interestingly, I was actually trying to use the “Record changes” function when I discovered this. I have had no problem using “Record/Show changes” through early May 2020. I used it last spring for grading papers, and text color would automatically change to reflect changes. I tried to use "Record/Show changes yesterday, and text color was not reflecting changes. I went into options for Writer and selected colors for “Changes,” but there’s still no change to text color. Interestingly, when I save the document to MS Word format, the resulting Word docx file did reflect changes, but not according to the colors I had specified. Love LibreOffice. Help?