The Menu Bar is not displayed

Xubuntu 18.04 thru 20.04
LibreOffice 6 and 7

For as long as I can remember, LibreOffice has not displayed the menu bar. I’d like to get it back. I searched the internet and this appears to be a frequent problem, but no solutions were obvious. One suggestion was to purge and reinstall the libreoffice-gtk package. I did this with no positive results. I’d appreciate suggestions on where to look to fix this problem. (I’d try looking under View-> Toolbars – assuming it exists – if only I had access to the View menu!) I hoped that installing LibreOffice 7.0 would correct things, but no. I do not believe that anything was manually changed under ~/.config/libreoffice but I’d be happy to look if someone has pointers. Thanks.

Search this site, this question has been asked several times recently. Not familiar with Xubuntu (desktop is Xfce, I assume), but this might be a package relationship issue. Ensure that the GTK+ libraries are installed. Check that the LO installation brought in the correct widget handling library (you mention libreoffice-gtk but it relies on the GTK+ system libraries which should be installed). Verify that no other LO interface has been installed such as libreoffice-kde5 or libreoffice-kf5 (for Qt widgets). libreoffice-x11 may be a good fallback wit Xfce. Eventually, disable OpenGL in your system.

BTW, tag meta is used for questions related to this AskLO site. Please retag to replace meta by common (problem affecting all LO applications).

Fixed the tag.

The libreoffice-gtk3 package is the GTK+ 3 integration. All the GTK3 elements appear to be installed.

I see no rogue LO packages installed. LO v.6.4.6 is installed as a standard package. I’ve downloaded 7.0 and manually installed it in my local software directory. I have not overwritten any of the files under /usr with the manual installation so I don’t see how these two installation can be interfering with one another, yet neither display the menubar. Without it I cannot customize either installation as I can’t get to Preferences/Options, etc.

How could OpenGL cause a menu problem like this with just this single program? There is nothing else on the system where the menu is not displayed and the menu used to display in prior versions. I suspect it’s a configuration issue. Is there any way using the keyboard to force the Preferences/Options pop-up to display?

If configuration in Xubuntu is similar to Fedora, try to move ~/.config/libreoffice/4/user somewhere else (or rename it) and launch LO. It will reintialise the user profile from scratch. If this works, you can try to salvage the backed up components of the user profile in case you want to recover your previous preferences (custom autotext or spelling exceptions – if you have none, leave the new profile as is).

To save tag modifications you must press Enter twice.

ajlittoz, thanks fir the great suggestion. However I tried removing the user directory first, and then I removed the entire config directory and allowed it to be recreated from scratch, and still the menubar does not display under any circumstances.

Then I’m short on suggestions.

You have no menu bar, but can you see other tool bars? You may eventually cumulate menu bar problems with other UI glitches. If you’re full screen, Ctrl+Shift+J will escape you from full screen mode (toggle action).

ajlittoz said

you can’t accept your own answer
because you need 20 karma points for

Hmmm, a chicken and egg problem. For which the answer is “a fish” (eggs pre-date chickens by several hundred million years.
Of course, if I quote cjsmall as saying upthread that

I solved the problem. Eventually I noticed that the menubar was also missing on the Clementine music player, so the problem, ii turns out, was not with LibreOffice.
then surely CJ can accept that answer?
Or is the system proof against such chicanery?

  1. This is not another solution to the problem and must be issued as an answer but as a comment under the relevant question/answer/comment. So please retype it where it belongs or use your more link to repost.

  2. The karma 20-threshold is an anti-spam measure to prevent spammers (yes, yes, AskLO is also a target for spammers, I have deleted many entries) from polluting the site by issuing a question and adding a so-pretending accepted answer immediately. Weak, I admit but better than luring users in making them think there is a real answer.

Wot? Re-post like that?

@Aidan: good, you passed your AskLO-driving licence test. Welcome among us. Become a regular contributor. You’ll discover other subtleties for this site (I can’t say the UI is one of the best; it is really awful sometimes).

I solved the problem. Eventually I noticed that the menubar was also missing on the Clementine music player, so the problem, ii turns out, was not with LibreOffice. From some hints elsewhere on the web I decided to remove the indicator-appmenu package and then had to reboot. This solved the problem. I’m not clear whether this module has any impact at all on Xfce4 systems, or is specific to Gnome only, but so far it hasn’t caused any problems and the menus are back. I’ll file a bug on that package.

Thanks you very much for your time and help. it is greatly appreciated.

You’re welcome.

As it is not a LO issue, please click on close link below your question or wait until Oct. 23 because I can’t accept your answer before Oct. 22 and you can’t accept your own answer because you need 20 karma points for that.

Hi, I’ve asked this very similar question: LO on OpenSuse Leap 15.2, new installation, no menu bar
As in my case the LO menus are inaccesible on an OpenSuse Leap 15 system, with KDE/Plasma Desktop, and all other menus I’m aware of are working fine, I’m not fully convinced that this is not an LO issue.
There’s also no " indicator-appmenu" package available for OpenSuse, so I can’t remove it :slight_smile:
Any hints what this package is doing “inside” (Application Menu Indicator in Launchpad), for a starting point to dig if there might be similar “LO-disturbing” defaults on KDE/Plasma? I beliebve it must be a default, as I have two OpenSuse boxes, one used for years, ugraded several times, LO working fine. And another, new, unchanged installation, where LO menus are not working, from beginning

@michaelof: as mentioned on the link you provided, indicator-appmenu is “part of Unity services”, i…e. the desktop based on GNOME used in Ubuntu. This explains why it conflicts with Xfce. As you are under KDE Plasma, there’s no indicator-appmenu and eventually installing it will cause problems.

You didn’t mention your LO version. I am also under KDE (but Fedora 32) and experienced serious problems with the UI when reinstalling my computer from scratch. I had installed incorrect widget packages. There are 4:

  1. libreoffice-x11 for basic X11 widgets (does not work if Wayland is installed)
  2. libreoffice-gtk3 for GTK+ widgets (GNOME, MATE and several other desktop managers)
  3. libreoffice-kde5 for Qt widgets (KDE, …)
  4. libreoffice-kf5 for KDE framework

Don’t use #4 kf5. It didn’t work on my PC and caused problems similar to the one described here.

Adapt the name to SUSE conventions.

See 228737/missing-menu-bar-when-lo-launched-from-root

SOLVED for my OpenSuse Leap 15.2 installation, also NOT a LO issue:

SOLUTION: disable the “Application menus daemon” background service in Plasma Settings