The problem with the line thickness of a border of a cell in Calc

The problem with the line thickness of a border of a cell in Calc. It seems the problem is old, but the solution could not be found. Description: in Calc, I can’t set the default line thickness to 0.5 or 0.75 PT instead of 0.05 PT (very thin!). Tried with styles (not saved) and with templates - if you set the border with borders, all cells get the borders of the specified value, and you need the default value to be applied only when I select a range and click the all borders button; if I create a template with the default thickness, but do not include borders for cells by default-again, when applied to the range, I get a thickness of 0.05 PT.
I want to be comfortable in excel: if a range can draw all the boundaries and that they were of normal thickness (ideally to have the opportunity to set it up) and to display a separate button in order to make it easier to draw a bold outer border without affecting the internal lines (in excel) via sidebar is not convenient, and the result is a too thick outer border.

I am surprised. I am using Libre Office in 2024. And the issue seems to be the same.
In case Hrbrgr can respond, here are the details:
Version: (x64) / LibreOffice Community
Build ID: 723314e595e8007d3cf785c16538505a1c878ca5
CPU threads: 4; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: en-IN (en_IN); UI: en-US
Calc: CL

Issue -
When I click the option to modify the outer border of a group of cells to bold, all the cell borders become bold.

I am sorry to ask this if this is resolved in some other forum. I am new to Libre office.

Please help me.

I want to be comfortable in excel:…

I want to be comfortable when I read the questions from questioners.

Therefore I would like to ask you to read this here:

Maybe you can design your description so that you know exactly when you’re doing something in Calc and when you’re doing something in Excel.

Then tell me which operating system and which LibreOffice version you are working with.
And in what file format do you save? Thank you.

The problem with the display with different line widths mostly lies in the cooperation with the screen.

Try a higher zoom level.

  1. There is a link that I found:
    Creating BORDERS Problem - #3 by jimk
  2. I tried a different approach:
    instead of using any click options from menus,
    → I selected the cells → format cells → Borders → ’ Format outercells with out modifying inner cells ’ icon option ( A block border with red inner lines)

Voila! I got only the outer cells’ borders modified.