Toggling text styles changes who word

Hello there,

My question is similar to this one from February of this year:

When I am typing out a bibliographic entry in Chicago Style in LibreOffice Writer, I type the author’s name, insert a common, use command+I to activate italics, type the title of the book, then use cmd+I again to stop typing italics in order to place a comma in roman after the after the title.

However, when I hit cmd+I that second time, it removes italics from the whole previous word. Is there a way of addressing this, or something I can do to tell LibreOffice that I am done with the word in question without adding a space?

It is a small issue, but I work as an editor and I need to make sure that text styles are applied accurately, and this makes it much more likely I will introduce errors into the text.

I am using a MacBook Pro (early 2011) with High Sierra (10.13.6). I regularly work in both English and French and have changed very few of the default settings in LibreOffice (

Thank you for any help. I’m grateful for the excellent community here.

Both in English and French? When this begin to happen? After an update?
Not with me in English. LibreOffice (x86); OS: Windows 6.1.

Doesn’t happen here in in any language, OS: Fedora Linux 34. Are your documents saved .odt (though this does not seem relevant here)?

Important advice: as you are an editor, and want to make sure text styles are applied accurately, don’t direct format but apply character styles instead of Ctrl+I. By default, Emphasis is associated with italics. By using a character style, you can change the emphasis from a single location without tracking all occurrences. Also, italics my mean different things: emphasis as already mentioned, foreign words, comments, irony, … By defining one character style per role, you can separate the formatting for the various semantics (even if you end up with italics in all of them). This is part of semantic markup, a way for an author to enrich his/her text with valuable meta-information.

1 Like

Thank you for your thoughtful answer (and LeroyG as well!). I was waiting until the issue occurred again in order to reply, as it doesn’t happen all the time and your responses made clear that I need more information.

It seems like it only occurs if the word I am typing is adjacent to other text. Still in terms of bibliographical entries, for instance, sometimes I write the page number first (even though it is the last thing in the entry) because I will be leaving the page to flip to the front matter for the rest of the information. So I will have something like:

I then place my cursor at the beginning of the line, type the author, activate italics, and type my title. This gives:

Adèle Chamoiseau, Les portes de l’enfer61.

I then then deactivate italics before adding a comma and hitting space and it takes the italics off the whole last word:

Adèle Chamoiseau, Les portes de l’enfer, 61.

If, before adding the space and the comma, I hit cmd+I again to undo the removal, I get:

Adèle Chamoiseau, Les portes de l’enfer61.

I found a discussion on the Apache OpenOffice forum from 2008 that says this is the intended behaviour:

The idea being to allow the cursor to be placed in the word to modify style rather than forcing the user to manually select the text. It also says this cannot be disabled.

Is it able to be disabled now? Or should I just change my habits – it would probably be as easy as just adding a space before the page number in my example above before I start typing.

Thanks again,

ps- I don’t know why the extra line breaks aren’t displaying around the examples above, I’m sorry if it makes it hard to read

Yes. That’s the way.

For Writer “l’enfer61” is one word (see the status bar when you select it).

Great. I marked your last comment as the solution. Thanks for your help.