Track changes mysterious colours

I choose to set the track changes colours to red for deletions (crossed out) and blue for additions (underlined). It makes it clearer. It is an option I have chosen since way back.
Recently I have been getting some of the text which I delete appearing in green (double crossed out) and the text which I add in green too (double underlined). This is confusing.
Please can someone help my understand what is happening.
Attached is a pscreen grab of the mess I am getting.

1 Like

I saw that you save your document in for DOCX, that could cause problems.

83482 HB Green

It could be a compatibility problem between
ODT and DOC / DOCX .


Recommendation for a clean work with LibreOffice, if different Office programs are used, or foreign formats ( DOC / DOCX ) are used in LibreOffice.

Old files in foreign formats must be converted in ODF and possibly adapted.
Files created in LibreOffice are to be saved in ODF format (ODT, ODS, etc.).
Always keep these files as source.

If you need other formats to share with partners, you can open an ODF file and use ″Save as…″ (copy) to save it in another format and share it.
This way you always have working files available on your system environment.


Edit different file formats in LibreOffice

Please report the behavior also as an error in Bugzilla .

See also:

How to Report Bugs in LibreOffice .

Please post the link to the bughere.
format: tdf#nnnnnn (use only the number, not the link)
To do this, edit your original question. Thank you very much.

1 Like

Sorry about that, it was a file I was working on in ODT format, and exported to DOCX. This image is what I was working on, and the problem starts there, and survived the translation
This is my environment:
Version: / LibreOffice Community
Build ID: 30(Build:2)
CPU threads: 6; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Ubuntu package version: 1:7.3.6-0ubuntu0.22.04.2
Calc: threaded

If I can tell you more, please ask.

I think you are on the right track with the ‘hint mode’. How can I turn that off?

As I indicated in my answer, the “possibly move” highlightling is not configurable in Tools>Options, LibreOffice Writer>Changes (which, IMHO, shows that this new feature is quite experimental and not harmoniously integrated with the rest ot the Track Changes feature).

Unfortunately, you enable/disable Track Changes as a whole. You can’t select what should be shown, which anyway wouldn’t make sense. While developers don’t create a specific colour settings, you’ll have to live with it.

1 Like

… and consider asking for that to be configurable by filing respective bug report (I consider it a bug).


Thank you for the clarification.

1 Like

Release notes for 7.3 has other track changes listed for Writer: LibreOffice 7.3 Community: Release Notes - The Document Foundation Wiki

1 Like

I also think it is a bug. The feature does not work very well. Maybe it makes sense with lists but it makes track changes not very usable with small inline changes. I reported it here: Please upvote.



Please note that the only way to “upvote” is adding oneself to CC list. The size of that list (and the number of duplicates) is the metric used as the bug’s popularity. Comments there may only be useful if add important missing bits of information; any “me too” or “how dare you not fix it yet!!!” kind of comments only clutter the issue, and decrease chances that a volunteer developer picks it.

Thanks. A CC is what I meant. Probably haven’t expressed myself clearly.

You didn’t mention your LO version which is a very important information. Recently (this is where LO version is relevant), Track Changes introduced a new “hint mode” where Writer tries to guess if words or groups of words have been moved (dragged from one location to another one). It highlights such sequences in a specific (presently) non-user controllable way. This might be what you’re experiencing.

In your case, if I’m right, you replaced “for example” with a long sequence ending in “which she”. One line down, you suppressed “which she”. The heuristic decided it is a move operation. As you can, the algorithm is not perfect.


Is there a way to turn the move text off?

What was the last version before it was introduced?

1 Like

If not turn it off, then change the appearance so it can be ignored. In other words make it look like deleting and adding.

Same question asked as 85926