Trouble including image control in Base report header

Hi all,

I am using LibreOffice 5.1 on Ubuntu 14.04.

I have a database with several tables. One of the tables (Table1) has photographs of objects. Table2 has microscopy images of some regions of these objects. So I have only one picture per object in Table1, and several pictures per object at Table2. I created a relationship between both tables, to connect the object in Table1 to its images in Table2. All the images are linked in the tables (full path), not embeded, in order to have a smaller filesize.
(see External Links to Images in Base Reports? and
[Tutorial] Pictures in Base (View topic) • Apache OpenOffice Community Forum)

So, I made a query with all the relevant fields. Afterwards, I created a report through the Report Builder (Design View), because I found that it was the only way to include images linked in tables. In order to do that, I included control images.
I have created the report with two groupings: first, a simple clasification of the objects (nevermind…) and second, by object.
So I have two headers-footers and one “details” section.

All the text fields display correctly everywhere. Images in “details” section (Table2) display perfectly. But the images in Table1 (in one of the headers) do not show at all.

Any ideas on this issue? Is there a limitation on displaying images or image control on headers?

Best regards,

Edit by Ratslinger 10/25/16 (relocate addition info from answer):
Hi, so, thanks @Ratslinger, a few editions:

I can input the images now. There was a small problem with the formatting of the path (there where two fields with the path in different formats and I used the wrong one for the query, sorry).
Now I have a problem with the format of the report, should I write a different post? The problem is that I want to try to insert a page-break after the end of the list of “details” of all elements in one group, then start in a new page, etc. I tried to configure that on “grouping and sorting”. If I select Keep together–>All, it does a weird thing: The first group header, followed by the second header is kept in one page. Then, all the “details” start in next page. I would like to keep the “details” in the same page of the corresponding header, and only break to a fresh page for the next header.

Header 1 – Header (1.a) - Element i - Element ii (break) – Header (1.b) - Element i - Element ii (break) Header 2 – Header 1.a etc

But I get:

Header 1 – Header (1.a) (break) - Element i - Element ii (break) – Header (1.b) (break) - Element i - Element ii (break) Header 2 – Header 1.a etc

The problem you may be having might be in the structure of the input to the Report Builder. Using this query as input:

image description

and using the Link field as the group, the following was produced:

As you can see, the group image was included in every record even though it is only used in the Group Header. Unfortunately, Report Builder only allows one input. It may be possible (haven’t tried) to have a multi-record type View as input and possible data manipulation through macro coding.

This was done in LO v5.2.0.4 on Xubuntu 16.04 system.

(P.S. thanks to for links to images on this post)


The problem lies within the General tab for the appropriate Header sections.

Check each header selection and set Force New Page for either None or Before Section.

O.K. Ratslinger

Hi! Thank you very much for your help.
I will edit my question, since I made a few mistakes.

Thanks again! I hadn’t see that option!! I will play with the “force new page” of the different sections to find the best result. How can edit the title to mark as “closed”?

You’re welcome. To close a question, click on Xclose at the very bottom of your original question.