Two errors while creating a new table using Firebird embedded

I’m trying to learn LibreOffice Base, using Firebird Embedded, on a Windows 10 (64-bit) desktop.
While trying to create my first table in a new database, I received the following errors when I tried to save it:
Table Definition:

  • There are no spaces in the table name.
  • There are no spaces in the field names.
  • The longest field name is only 24 characters.
  • The only special character in the field names is the underscore _ .
  • I do have one large text field (Text [VARCHAR]) with a length of 3000.
  • There are 55 fields in the table (I know… seems like a lot, but most of them are Yes/No types so I can filter).

Does anyone know why I may be getting these errors?


Did mention already that Firebird has its’ own baggage.
See this post → LO Database newbie - Firebird error trying to create new project

I won’t create the table at once. Take the first 30 fields, save the table and add the other fields.

Length of 3000 in varchar shouldn’t be a problem. 8000 had been the limit for UTF8.

You did warn me @Ratslinger that Firebird did have baggage. lol.
Saving the table a few fields at a time did work, @RobertG . I entered the exact same fields, exact same types, exact same length… and it worked.

Only one info: Have tried to reproduce this with a table imported from Calc to Firebird database. 61 Fields in this table. Has been created without any problem. So I couldn’t write a bug for this.