Two issues with Report Builder

I’m trying to create a report within Base, and have come up with a problem and a question:

  • I have set the Detail record to ‘keep together’ but it doesn’t. The fields are split across page boundaries. Is this a known bug or am I doing something wrong?

  • Is there any way to get a free-form text field to occupy only the space used? At the moment I’m having to increase the size to the maximum depth of the text.

Version: (x64)
Build ID: dd0751754f11728f69b42ee2af66670068624673
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win;
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded

Any help would be welcome.


[later] Here are screen shots of the report builder and result.

[even later] I’ve attached a cut-down copy of the database. Run the report and look at the bottom of the first page. I use European A4 size paper, by the way.WinesTest Bug.odb

hello ptoye,

grouping by name appears to fix the issue.

use the ‘Sorting and Grouping’ dialogue like so:

would also like to say that the ‘Auto Grow’ feature referenced in the answer by Ratslinger works well.

Thanks @cpb. I’m sure I posted a comment here yesterday to that effect but it somehow didn’t appear. Finger trouble I expect. You’re absolutely right - I need to take the sort/group down another level. Now it’s sorted so I’ve marked it as an answer to question 1.


1st item → Force new page Base Report

2nd item - new in LO 6.4.x from tdf#45789 Auto Grow:

image description

Thanks @ratslinger.

  1. I don’t quite understand this. I looked at your link and set the Sorting and Grouping Keep Together as you suggest but I still get the detail level split between pages. I’m putting screenshots of the report builder and the result into my original question - it seems you can’t put images into a comment.

There are two ‘Keep together’ menu items and it’s not at all clear what each of them refers to. I’d have thought that Keep Together for a group would refer to the whole group, while for a detail it would refer to each individual record. But that’s obviously not the case.

  1. That’s good news! Is 6.4 stable yet?


    • Have not been able to duplicate the problem using Ubuntu 20.04 Mate with LO:

    Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
    CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3;
    Locale: en-US (en_US.UTF-8); UI-Language: en-US
    Calc: threaded

  1. What is stable? In my opinion LO 5.x Base is not stable.

OK. Was finally able to get a similar result. There is also a Keep Together setting in the Detail section. If set to No get your result. Mine had been set to Yes.

Thanks again @Ratslinger. Sorry for the late reply - I didn’t get an email saying you’d answered.

  1. This is odd on two counts. Firstly, one would think that setting Keep Together to No would allow a split. Secondly, I can’t replicate your result. I’ve tried (I think) every combination of Yes/no/With first detail in the Sorting & Grouping menu with Yes/No in the Detail properties and always get the same result: the record is split over the page. I thought it might be that I had two Sort/Group fields, but deleting one of them didn’t make any difference. Very odd.

Would it help if I sent a copy of the database file to you? There’s no highly personal information in it. I’ll remove the macros and try to cut it down a bit first.

  1. LOL


A sample is probably the only way to get any further. Please post in edited question.

@Ratslinger. Done that. Hope it works OK.

Again, sorry for the late answer - no email received.

Do not find a fix. Should report → Bugzilla

with reference to my answer:

your report is actually displaying the data exactly as instructed.

you declared 1 group ‘Style’.

you can not and did not group by ‘Price’ because grouping by both ‘Style’ and ‘Price’ would result in a huge amount of white space.

you sorted first by ‘Style’ then by ‘Price’.

in order to split records which are priced identically within the same ‘Style’ group a unique value on which we can group is required, that value is the field “Name”.


Is this a mis-placed comment? This is not my report nor did I set any of the grouping.

However, even though your fix worked, I do not agree with the reasoning. If you instead sort in the query and then in the report remove Price from Group/sort dialog leaving only Style the problem remains. Adding Name again resolves the issue but I am not clear as to why.


As a secondary note, grouping by both ‘Style’ and ‘Price’ does not require much space.

Have seen that replacing Name with Comments also works and other choices produce different results.

yes my comment is misplaced, it should have been targeted at the original poster. sorry but unable to fix as comment can not be edited!.

the sample database is small with a handful of records.

we begin by declaring one group, ‘Style’.

to prevent an individual record from being split between two pages we must define a second group.

each record in the report occupies between one and four rows.

empty rows (white space) will be generated when our second group contains more rows than remain on the current page.
the number of rows required per group is the number of rows in that group.

continuation of previous comment.

the only field within the group ‘Style’ which is guaranteed to be UNIQUE is ‘Name’.

so the second group has to be ‘Name’ and the number of empty rows (white space) if/when generated will never exceed three.

if instead the second group was ‘Comment’ and ‘Comment’ was duplicated only once the number of empty rows (white space) if/when generated could be as many as seven.

if the second group was ‘Price’ and ‘Price’ is in fact duplicated many times then the number of empty rows (white space) generated would be unacceptable.

obviously as the database grows it may contain many hundreds or even thousands of records which will amplify the white space issue.

@Ratslinger Thanks for these comments - @cpb has hit the nail on the head but your answers raised another minor issue - see my comment to his/her comment.


Still don’t agree with your explanation. Duplicated comments in a few records and used that vs Name but did not see these additional white space rows you note.


Do not see any comment of yours as mentioned.

@Ratslinger I’m sure I posted one but it didn’t appear. There’s a comment there now.

I’ll try out LO 6.4 when I have time to download & install. Do you happen to know if it’s possible to have two versions of LO installed at the same time or do they interact?