Typing a space in a Hebrew documents causes lag

Windows 10 pro (32 bit)
LibreWriter Version:

A very noticeable lag of 2-5 seconds (almost) whenever I type a space. Nothing like that happens when I use English.

It could be the same problem I’ve noticed: Auto-correct causes high cpu usage when typing Hebrew or Arabic
Could you try to disable auto-correct and see what happens?