Unable to connect to Google Drive, LO 5.3, UBUNTU 16.04

I just tried, to connect to Google Drive directly from “open remote file” option within the file menu of LibreOffice. I do get an email from Google acknowledging a new sign-in from LibreOffice but I continuously get a “General I/O Error”. I have seen some user having the same problem with earlier version, I have seen that this feature works fine with Windows10. Does anyone has a solution for Ubuntu 16.04? Find below details of my installation.

Build ID: 1:5.3.0~rc3-0ubuntu1~xenial1.1
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; Layout Engine: new;
Locale: en-US (en_US.UTF-8); Calc: group

Ubuntu 16.04 LTS

Sorry. no answer here. Had to register to see that:(


Have this working on several linux distros & Gmail accounts. First time kept asking for a confirmation code. Then discovered that by first opening the Gmail account and while opened, I was able to connect using Google Drive. This seemed to allow authentication. Once done, Gmail need not be signed on to.

Edit 3/7/2018:

Have done some further testing. Prior to today, all my testing was performed WITHOUT 2-Step verification on. Today I turned on two step verification with code sent via text as the second step. THIS is the 6-digit code which is required to be entered. Test was done with LO v6.0.2.1. It is my understanding that some early 5.x versions did not accept this second step.

Can you please clarify how you log in? I have opened Gmail and Google Drive in a browser (Chrome) and connected to Google via the Gnome Control Centre but it is not making any difference.
I am using Ubuntu 17.10.

As I don’t use this normally, I just tested again. A normal sign in is from an LO document. From menu File->Open Remote File which brings up the dialog for remote files. If first time add a service, put in pertinent information & go from there. As stated above, the first time connection needed to have my Gmail account open while performing the connection through LO. After the first time don’t need Gmail opened first.

Thanks, but I do exactly that and it still asks me for a 6 digit code, which I am never sent. I am logged into Gmail in Chrome but it makes no difference. I am using Ubuntu, as in the original question, but version 17.10.

Sorry I can’t be of more help. I have three accounts set up that way and all working. Using Chrome & Mint 18.2

this actually worked for me, somehow :smiley: I don’t have 2FA set up, i tried to connect yesterday and it asked for pin, today i just tried to open gmail in chrome and then tried to log into LO and it worked without asking for pin :open_mouth: thanks, would upvote but i don’t have reputation :confused:

YOu can use gnome online accounts and use the google drive like any other folder

I got this from the help menu in LibreOffice Version:

Connecting to Google Drive In the File Services dialog, set:
• Type: Google Drive.
• User, Password: the username and password of the Google account.
• Remember password: Check to store the password in LibreOffice’s user profile. The password will be secured by the master password in Tools - Options - LibreOffice - Security - Internet passwords.
• Label: give a name for this connection. This name will show in the Service listbox of the Open or Save remote files dialog. Once the connection is defined, click OK to connect. The dialog will dim until the connection is established with the server.

But this 6 digit pin is a headache. I have a 4 digit pin set up at my Google account. Not a 6 digit :frowning: :frowning:

image description

@ahmed2015shamim This is not an answer. Answers are to respond to original question.

Don’t know why my answer doesn’t work for others. Just did it again on two different gmail accounts. It asks for ‘6 digit pin’. Cancel just that box & leave rest open. Sign on to your gmail account in a browser (I used Chrome). With the gmail account open in the browser, click OK on the dialog box left open & it connects for me. After this initial procedure, I don’t need my gmail account open in a browser.

No authentication (4 or 6 pin) needed! Have now done this at least 10 times.

Also, just did a third different account where I signed into gmail account on browser first then tried remote for this third account from Writer. This time it DID NOT even ask for 6 digit pin.

LO 6 just installed windows machine, attempt to connect to my Google Drive getting same problem of requesting 6 digit pin. BUT…

My 2f auth works through it and I get the text from Google asking if I just attempted to sign in. I reply using the YES it is me option and click through… Pin still being required anyways…

Tried the gmail account opened in Chrome browser while making another attempt, same problem… it still wants the PIN.

any way to help put a check list of what to try?

@traacker Please see edit in my answer.