Unable to copy and paste Zotero Citations to a specific LO-document


I am working with LibreOffice and Zotero 6.0.4 on macOS Catalina. I have been working on a long LO document (about 400 pages) for some time which includes a lot of Zotero citations. I sent part of the text to a proofreader (in a newly created document), who read/corrected it with LibreOffice. Now, I want to copy the corrected text of the proofread document into my old, longer document, but am unable to copy/paste the zotero citations, as they get lost (they are not preserved, the citation links are gone). This is weird, since copying them from the proofread document to another, newly created document, works. Also, copying citations out of another random LO-document to the long document always works. I can’t figure out, which document is the problem here, since only the combination of those two specific documents does not work. I want to avoid manually adding all the citations again, so what do I do?

Thanks, Sofia

p.s. I already consulted with the Zotero-developers, who could not figure out the problem. I therefore think it must have something to do with LibreOffice.

Have you looked to see if anyone has solved the problem? See:

50+ results for zotero

Yes, I did. But the problem I experience is quite specific.

1 Like

Are you sure your proofreader didn’t erase the Zotero-specific data?

Zotero is not integrated with the general Writer machinery (because, I assume, developers want their product to be suite-agnostic and “portable”) and operates with a bunch of macros. The net result is it messes up “professional” formatting with styles and makes it impossible to format Zotero citations and insertions with styles.

I suspect that the Zotero special markup has been lost at some step. Unless you have very specific needs, i.e. sharing your citations between several “incompatible” applications, you’b better use the built-in citation features. They don’t pretend to solve the same general problems as Zotero and restrict themselves to only the insertion of citation keys in text and building a bibliography, but they do it fine and reliably.

If you want a more targeted analysis, attach a portion of the proof-read document with a comment identifying where to look at/copy (one good occurrence, one faulty occurrence). Note however that I don’t intend to install Zotero for the text.

Hello again.

In the proofread document the zotero citations are still active (they have grey underlining, the link appears when I place the cursor on them, I can edit them). In my documents, the citations are always in the footnotes. So I tried to copy text (including some footnotes with citations) to another document and it worked. The only combination that does not seem to work, is between those two specific documents (proofread document and long document).

At this point, I cannot switch to another system (if that was what you meant in the 2nd paragraph), since I have been working with Zotero for years and have a huge bibliography.

My IT knowledge slowly but surely reaches its limits here and I am not able to understand everything you’re writing, to be honest. I need a customer friendly solution, since I already have lost two days with this problem which seems to be a LibreOffice bug. I do not really know what you mean by “one good occurrence, one faulty occurrence”.

Portion of proofread document.odt (16.9 KB)

I just wanted a “working” citation and a “failing” citation in the sample. But you seem to say that they are all failing when you try to copy them into your original document.

Reading the sample, now.

Yes, that’s right, all the citations are lost when I copy them into the original document.

Thank you!

I just had a look at the internal encoding of the sample and don’t see anything obviously unusual but I am not at all an expert in Zotero stuff. Copying a note to a fresh document transfers all Zotero data apparently.
(Once again, I didn’t install Zotero. I can only tell that all the hidden stuff is copied without guarantee for it to be functional.)

What may happen, it is only a supposition and I can’t check it, is that the pasted stuff has lost some necessary data (which? how? when?). Zotero data is highly structured with parameters enclosed in [ ] and { }. If for any reason, a delimiter near the end or beginning of the copied stuff is missing, Zotero will not be able to parse correctly the data and will reject it.
A similar possibility lies in the destination location of your pasting. If it lands inside some existing text already containing the delimiters, nesting may become unbalanced.

Have you tried pasting in an empty paragraph? I mean a really empty one.

Thank you for looking into that.

I get what you’re saying in the second paragraph, but as far as I can tell the data are all there, because I created a new/fresh LO-document and tried to copy the citations there and it worked. They only disappear when I copy them into my long document. I also tried to paste different citations/ text passages in different places of the long document (including an empty paragraph), but still they disappeared.

I tried updating both LibreOffice and Zotero to the newest versions and now I seem to face an additional problem: the ZoteroToolbar in LibreOffice won’t work properly any more (I reinstalled the ZoteroLibreOfficeIntegration and checked that a JAVA/JDK environment was selected). When I try to add a citation now, the citation-placeholder appears, I can select a publication in the dialogue-window that pops up, but the placeholder is never replaced with the actual citation. This is something that always happens when I update LibreOffice. I am sorry for introducing a different problem here, but maybe you can help me out. In the past, this problem did sometimes solve itself, since I sometimes had to wait very long (maybe half an hour) for the first citation (after an update) to appear where the placeholder was. Maybe you can help me out here?

update: the toolbar now works again, but since this is a recurring problem a tip for future use would still be appreciated.

if this question is actually about Writer, please re-tag your question to help others looking for solutions. Thanks.

1 Like

@Sofia: if the citations “disappear” in the real document, you may (once again, it’s a supposition insofar as I have no idea about your document) have an issue with formatting. Perhaps, a style or some unexpected formatting flag is applied causing the paragraph to become hidden.
If your sample file is representative of your document, I fear it is inconsistently manually formatting (my clue: the sample file uses Default Paragraph Style, but I didn’t mention it because it was a sample file). Pasting may cause accidentally some conflict.

@BigRAl: I’ll do it for OP.

1 Like

thanks. I could have done it, but I was not certain if Zotero could be used in other LO components :wink:

@ajlittoz : Thank you, this makes sense (or it sounds like it), I will try to figure out if that could be the problem. In the zotero-Forum I also received the following suggestion

@BigRAl: Ok, thank you. If the problem persists, I will open a new thread.

Cross-posting at https://forums.zotero.org/discussion/96482/zotero-citations-get-lost-when-copy-pasting-to-a-specific-odt-document

I am sorry for the bad editing, I meant to delete my reference to the zotero forum since I realised it regarded the other problem that appeared after updating both programs and therefore was not thematically belonging to this thread. So please ignore it.

As you already provided a part of the proof-read text. Could you please

  • Copy a citation in an empty file
  • Copy a citation in a copy of your document, wich “looses” citation, then remove most other parts of the document (therefore use a copy)
  • Post both files to compare them (to check, if all data is lost, or maybe
    available, but unusable by Zotero)

If this gives no lead, the question is, why this document gives you trouble, as it seem to work in other places… Difficult to find

Anything special in this document, besides usung Zotero? Do you track changes in this file?